Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 14 of 14

Thread: Z5 acting strange

  1. Back To Top    #1

    Join Date
    Dec 2014
    Location
    Mustang, OK
    Posts
    9

    Z5 acting strange

    I've had this thing for about 3 months and haven't used it a lot due to the weather, but the times I have used it, it did a great job...until recently. All of a sudden, it's less responsive to the remote, it seems to want to go in tight circles and doesn't seem to actually run very long.

    Anyone experienced any of this? BTW, my pool's chemistry isn't very good right now due to it being a new build, but it never was a problem until just the past few weeks.

  2. Back To Top    #2
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: Z5 acting strange

    Welcome to TFP Kevin!

    Can't say I've heard that yet, but this particular unit has only been out about a year now. We have a few Z5 owners, my buddy has one, and this is the first I've heard about any trouble like this with them. Perhaps someone else will weigh in.
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

  3. Back To Top    #3

    Join Date
    Dec 2014
    Location
    Mustang, OK
    Posts
    9

    Re: Z5 acting strange

    Sending in for repairs.

    BTW, I have to pay shipping costs. I've used this thing a total of about a month and I have to pay shipping on warranty work. No bueno.

  4. Back To Top    #4

    Join Date
    Dec 2014
    Location
    Mustang, OK
    Posts
    9

    Re: Z5 acting strange

    Got my Z5 back from Maytronics. They had to replace the motor. They were very prompt in getting it back to me. Still hard to swallow $70 shipping costs.

  5. Back To Top    #5

    TFP Guide
    mrcarcrazy's Avatar
    Join Date
    Jan 2014
    Location
    Odessa, TX
    Posts
    973

    Re: Z5 acting strange

    Fwiw. In the manual it has a pretty narrow ph range to operate in. I don't know that the "out of whack" chemicals caused your issue. But they couldn't possibly help motor life.

    Something to consider at least.

  6. Back To Top    #6

    Join Date
    Dec 2014
    Location
    Mustang, OK
    Posts
    9

    Re: Z5 acting strange

    Could be, but my Z5 probably didn't have 25 hours on it.

  7. Back To Top    #7

    Join Date
    Oct 2007
    Location
    Parkland, FL
    Posts
    727

    Re: Z5 acting strange

    Quote Originally Posted by mrcarcrazy View Post
    Fwiw. In the manual it has a pretty narrow ph range to operate in. I don't know that the "out of whack" chemicals caused your issue. But they couldn't possibly help motor life.

    Something to consider at least.
    This is nonsense. Maybe over a number of years this might affect something, but certainly not so quickly. I've run with PH out of wack, with FC over 45 and even cleanup after a hurricane with parts of a screen enclosure in the pool.
    8000 gal diamond brite pool with 650 gal spillover spa, Pentair 3hp VS pump. Jandy Cartridge filter and Jandy Heat Pump. Jandy PDA automation system with 2 Pentair Laminars. SmartPool NC74S Robotic Pool Cleaner.

  8. Back To Top    #8
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: Z5 acting strange

    Let's relax a little bit here...

    I think Mcc was just going by what the manual said, and merely offered a suggestion. While I'm embarrassed to say it, I never even saw a pH range in my manual.

    Maybe I should go back and read it, but I'm not worried I'll be out of range. ALL pool equipment Mfgrs usually stay within whatever guidelines are set forth by regulatory agencies no matter what products they are selling. Not knowing what the manual says, this could be what they list and why.

    Whatever the case, I would tend to think chemical issues would have to be pretty extreme to cause a problem.
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

  9. Back To Top    #9

    Join Date
    Jun 2014
    Location
    Rogers, AR
    Posts
    412

    Re: Z5 acting strange

    Quote Originally Posted by kevindlegg View Post
    Got my Z5 back from Maytronics. They had to replace the motor. They were very prompt in getting it back to me. Still hard to swallow $70 shipping costs.
    No matter the reason, I agree it would not make me happy to pay shipping when the unit is still so new. I would think they would pay a portion of it. You spend a lot of money on these things and unfortunately every once in awhile you get a dud and usually my luck goes that I am the one who gets the bad one.
    16x32 IG rectangular 21,800k new vinyl liner 2014, Triton II TR 50 sand Filter, Pentair 3/4 hsp whisperflow pump, 3 returns, TF100 test kit w/speedstir. Maytronics s 300i robot.

  10. Back To Top    #10

    TFP Guide
    mrcarcrazy's Avatar
    Join Date
    Jan 2014
    Location
    Odessa, TX
    Posts
    973

    Re: Z5 acting strange

    Quote Originally Posted by kevindlegg View Post
    Could be, but my Z5 probably didn't have 25 hours on it.
    probably just a bad motor or seal if it was that new.

    Quote Originally Posted by robl45 View Post
    This is nonsense. Maybe over a number of years this might affect something, but certainly not so quickly. I've run with PH out of wack, with FC over 45 and even cleanup after a hurricane with parts of a screen enclosure in the pool.

    You should re-read my post.
    IG gunite/plaster pool/spa Started 1/17/14, Plastered 5/16/14
    Size: 12'-21'x39' free form, depth ranging from 4' to 7, attached 6 person spa with spillover.
    Equipment: Whisperflo 2hp pump, Pentair 30" sand filter, Pentair Mastertemp 400k BTU heater, 1hp Whisperflo for waterfalls, and a blower for spa floor

  11. Back To Top    #11
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: Z5 acting strange

    I assure you, I would not be happy about return or any amount of shipping. No question that it stinks, and they ought to pony up and cover that under warranty. It would be quite easy for them to send a shipping label.
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

  12. Back To Top    #12

    Join Date
    Dec 2014
    Location
    Mustang, OK
    Posts
    9

    Re: Z5 acting strange

    I wouldn't be upset if not for everyone else that I've ever dealt with covering shipping for a warranty repair.

  13. Back To Top    #13

    TFP Guide
    mrcarcrazy's Avatar
    Join Date
    Jan 2014
    Location
    Odessa, TX
    Posts
    973

    Re: Z5 acting strange

    Quote Originally Posted by kevindlegg View Post
    I wouldn't be upset if not for everyone else that I've ever dealt with covering shipping for a warranty repair.
    I feel you. I threw a fit when I had a similar experience (funny, it wasn't that long ago and I already don't remember who/what/why). I definitely understand that. Hopefully that's the last issue any of us have!
    IG gunite/plaster pool/spa Started 1/17/14, Plastered 5/16/14
    Size: 12'-21'x39' free form, depth ranging from 4' to 7, attached 6 person spa with spillover.
    Equipment: Whisperflo 2hp pump, Pentair 30" sand filter, Pentair Mastertemp 400k BTU heater, 1hp Whisperflo for waterfalls, and a blower for spa floor

  14. Back To Top    #14

    Join Date
    Oct 2007
    Location
    Parkland, FL
    Posts
    727

    Re: Z5 acting strange

    I had to pay shipping when my blue diamond broke in 4 months, cost me 50 something dollars. Luckily after that, there was a local place to fix it.
    8000 gal diamond brite pool with 650 gal spillover spa, Pentair 3hp VS pump. Jandy Cartridge filter and Jandy Heat Pump. Jandy PDA automation system with 2 Pentair Laminars. SmartPool NC74S Robotic Pool Cleaner.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •