Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: pentair minimax 400- eo2 code-- help

  1. Back To Top    #1

    Join Date
    Mar 2015
    Location
    brentwood, ca
    Posts
    3

    pentair minimax 400- eo2 code-- help

    I have replaced everything on this unit!! The ignitor is working fine, replaced the flame sensor, replace the high temp sensor- the unit would fire then turn off.. then fire and turn off.. I looked into the problem further and everything pointed to the power element.. I just replaced it and I verified that is it working before I installed it and now the unit won't fire!! e02- high limit code. I have good water flow.. Help!!

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: pentair minimax 400- eo2 code-- help

    Welcome to TFP!

    Have you checked the high limit thermal cutout switches? I believe they are L1 and L2 in the wiring diagram.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,437

    Re: pentair minimax 400- eo2 code-- help

    Not sure which model you exactly have, plus or NT, but did you check the flow valve assembly?
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  4. Back To Top    #4

    Join Date
    Mar 2015
    Location
    brentwood, ca
    Posts
    3

    Re: pentair minimax 400- eo2 code-- help

    Quote Originally Posted by autohousemike View Post
    I have replaced everything on this unit!! The ignitor is working fine, replaced the flame sensor, replace the high temp sensor- the unit would fire then turn off.. then fire and turn off.. I looked into the problem further and everything pointed to the power element.. I just replaced it and I verified that is it working before I installed it and now the unit won't fire!! e02- high limit code. I have good water flow.. Help!!
    I have checked the flow value assembly- working fine

    - - - Updated - - -

    I tapped on the high limit switches- after hitting the 150 limit switch, the unit fired... then turned off after a couple min.. then fired and e02 code again. probably have a faulty 150 degree switch??

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: pentair minimax 400- eo2 code-- help

    Most likely. You can jumper across the switch to make sure. If it works with the switch shorted out, that is certainly the problem.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  6. Back To Top    #6

    Join Date
    Mar 2015
    Location
    brentwood, ca
    Posts
    3

    Re: pentair minimax 400- eo2 code-- help

    thanks for the assistance- I just ordered one- figured for the $35- I've replaced everything else it is 9 years old after all and for a nt400 minimax- I guess I've done pretty well up to this point!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •