Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Filter not building pressure

  1. Back To Top    #1

    Join Date
    Feb 2015
    Location
    Santa Clara,CA
    Posts
    43

    Filter not building pressure

    I noticed today that the filter is not building pressure.
    It builds pressure for like a handful of seconds to about almost 15psi and then drops to 0.
    Water goes through the skimmer for few seconds and then stops.

    This happened once in the past about a week back. After cleaning the restraining basket (near the pump) it just started working. I did the same today. No luck.

    I am new to this so I might be missing to provide some basic info. Any info will help.
    Should I open up the filter and see whats going on.
    I also tried setting the valve to back wash for few seconds. After water drains out for few seconds and I restart the pump, pressure builds up immediately (unlike earlier where it takes a few minutes) but then again pressure drops to zero again.

    Thanks in advance,
    -Prasad
    30,000 gal,20'x40' IG (3-8.5 with diving board) ,Plaster,Pentair S8D110, Type of filer - DE,TF-100 test kit
    Poolsafe Automatic pool cover

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Filter not building pressure

    Most likely air is getting into the pump strainer basket, causing the pump to lose prime. Is the pump strainer basket full of air when the pressure goes back to zero? If so air is getting in somewhere. The two most likely places to look are a low pool water level letting a vortex form in the skimmer that pulls air into the system, or a bad seal on the pump strainer basket lid.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Feb 2015
    Location
    Santa Clara,CA
    Posts
    43

    Re: Filter not building pressure

    Hi Jason,

    You just made me a lifetime TFP member

    You were right about air going in somewhere as there was bubbles coming out of the pool.
    I tightened the pump straining basket quite tightly. It did not help.

    There was enough water in the pool. I observed the skimmer and something weird was happening there.
    Water was going through the skimmer and suddenly used to stop. There was a small door between the pool and the skimmer that had locked itself the wrong way. I tried adjusting it and it got disconnected. I took it out right now.

    After this the pressue is back to about 12 psi.

    Thanks a bunch,
    -Prasad
    30,000 gal,20'x40' IG (3-8.5 with diving board) ,Plaster,Pentair S8D110, Type of filer - DE,TF-100 test kit
    Poolsafe Automatic pool cover

  4. Back To Top    #4

    Join Date
    Feb 2015
    Location
    Santa Clara,CA
    Posts
    43

    Re: Filter not building pressure

    On that note, Is that door/latch required or can I do without it.

    -Prasad
    30,000 gal,20'x40' IG (3-8.5 with diving board) ,Plaster,Pentair S8D110, Type of filer - DE,TF-100 test kit
    Poolsafe Automatic pool cover

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Filter not building pressure

    The door/gate thing at the mouth of the skimmer is called a wier. You can get away without one for a while, but it is much better if you have one. The weir basically allows the skimmer to skim, rather than just being a water intake. Or to put that another way, the skimmer will not remove surface debris without the wier.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  6. Back To Top    #6

    Join Date
    Feb 2015
    Location
    Santa Clara,CA
    Posts
    43

    Re: Filter not building pressure

    Thank you Jason. I fixed the wier back in place.
    30,000 gal,20'x40' IG (3-8.5 with diving board) ,Plaster,Pentair S8D110, Type of filer - DE,TF-100 test kit
    Poolsafe Automatic pool cover

  7. Back To Top    #7

    Join Date
    Apr 2014
    Location
    California
    Posts
    97

    Re: Filter not building pressure

    The wire acts to increase the pull across the top of the water which pulls debri into the strainer with out it water will be pulled in but across the surface it won't have the extra pull that the door creates

    - - - Updated - - -

    Also if the pump primed once the skimmer door/wier was off then your water level is to low because with the door on it was probably cascading down into the skimmer pulling air in like a waterfall

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •