Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Liquidator feed issue

  1. Back To Top    #1

    Join Date
    Jun 2014
    Dublin, CA

    Liquidator feed issue

    So I have had the liquidator for almost a year now and love it. But lately I've noticed some low chlorine levels.

    I check the chlorine level of the pool and its next to nothing today.

    I check the chlorine level in the water on the top of the liquidator and its almost zero even after adding 6 gallons yesterday.

    I give the tank a stir, and the chlorine level came way back up.

    Any idea why the chlorine isn't mixing properly? Am I doing something wrong
    30k in ground fiberglass pool with cartridge filters. Dublin (Bay Area) California

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Liquidator feed issue

    It sounds like you have something consuming the chlorine as it's introduced into the pool, and not a problem with the LQ (Liquidator).

    The chlorine concentration at the top of the water level in the LQ vessel should be very low. There should be a distinct line between the bleach and the water in the vessel. The bleach slowly dissolves into the water on top and is then dispensed into the bulk pool water as the pump runs.

    I suggest shutting the LQ down and running an OCLT to see if you have something consuming the FC.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts