Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Trouble With Baracuda MX-8

  1. Back To Top    #1

    Join Date
    Feb 2015
    Location
    Phoenix, Arizona
    Posts
    3

    Unhappy Trouble With Baracuda MX-8

    Hey All,


    So I have been having some issues with my MX-8. It has worked fine since I got it until recently. It keeps either getting stuck on the drain and will not move (stays upright), or ends up tipping over on its back at the stairs and tries like **** to climb the steps to no avail. I took it into a local pool store where they looked at it and told me the only thing potentially wrong would be the tracks, which I had them replace. Everything else was apparently fine, including the directional control devices. Normally, I would think since it's not the vacuum, it would be an issue with the suction, but the suction at the end of the line was at 3 on the suction tester, and the wheels rotate 10x in 25 seconds, which is par for normal operation. The suction towards the first segments of hose are a little bit higher higher (4 to 5 in a 7 segment hose), and when raise above the water, some of the connections sound like they are sucking in air. I wouldn't think this would matter if the proper suction is at the end of the line, but I could be wrong. Would it make sense to use PVC glue on the connectors or some other kind of epoxy to reduce the loss, or would I need to replace my hose altogether?

    A couple things to note:
    1) It is currently set to the larger debris setting and always has been.
    2) I have a dedicated vacuum line

    Any ideas?? Any advice is greatly appreciated.
    10,000 Gal, IG Pebble, Hayward Pro Series Sand Filter, 0.75kW Hayward Super II Pump, Rebuilt 2012 (California Pools), Baracuda MX-8 Cleaner

  2. Back To Top    #2
    Killer95Stang's Avatar
    Join Date
    Aug 2012
    Location
    Sunny SoCal
    Posts
    570

    Re: Trouble With Baracuda MX-8

    Have you tried running it with the suction reading 4 or 5 at the end of the hose? I know the manual says to adjust to 3, but mine seems to work with it a little higher suction. My MX8 hoses also make a squeal from air leaks every once in awhile as it maneuvers around the pool.
    Pool done!! (backyard = work in progress) 32' x 19' inground freeform with 7' spa, baja step w/ (2) bubblers, stonescapes mini pebble finish, rock waterfall feature, 12" raised bond beam, Intelliflo VS, Whisperflo feature pump, (3) 5G Color LED's, FNS + DE 60, 400K Master Temp, Easytouch 8 w/ remote, Intellichlor IC40, Vision Classic Ceramic Kamado smoker, Margaritaville DM1000!!! Party Coming Soon!!
    TF-100 Test Kit w/ Speedstir

  3. Back To Top    #3

    Join Date
    Feb 2015
    Location
    Phoenix, Arizona
    Posts
    3

    Re: Trouble With Baracuda MX-8

    I just tried it at 4 and at 5, gave it some time and sure enough it got stuck on the drain again. I did just replace the quick connector with the valve regulator, which supposedly doesn't allow any excess suction but I tried doing this before with the stock quick connector and it still ended up getting stuck.
    10,000 Gal, IG Pebble, Hayward Pro Series Sand Filter, 0.75kW Hayward Super II Pump, Rebuilt 2012 (California Pools), Baracuda MX-8 Cleaner

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •