Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: How much lube to use ?

  1. Back To Top    #1

    Join Date
    Sep 2013
    Location
    Dallas-Ft. Worth Metroplex, TX
    Posts
    810

    How much lube to use ?

    How much lube should be used to lube an o-ring? Sparingly or generously?
    14K Freeform Gunite w/60% Blue Quartz plaster, Quad DE filter, Intelliflo VS Pump + Booster for Cleaner, Aquacal Heat Pump

  2. Back To Top    #2
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: How much lube to use ?

    You gotta get that just right. I assume it is in pool plumbing somewhere? Don't need a bunch extra squeezing out. Really the goal is just enough to get it to slide into place without binding up.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3

    Join Date
    Sep 2013
    Location
    Dallas-Ft. Worth Metroplex, TX
    Posts
    810

    Re: How much lube to use ?

    I am trying to find out where I am getting air from because my pump basket gets a good amount of air in it. I've already replaced the drain plug O-Rings, and put Teflon tape on them. Today I cleaned and re-lubed the basket o-ring.. but I'm still getting air. I've tried both sparing and generous amounts of lube but neither makes a difference. Next I'll have to try replacing the O-rings on my 4 month old jandy "neverlube" valves for the main drain and skimmers. Brand new pool, but PB ceased all communication and all of his techs claim it's normal operation. You should see how much air gets in there. It's definitely not normal.
    14K Freeform Gunite w/60% Blue Quartz plaster, Quad DE filter, Intelliflo VS Pump + Booster for Cleaner, Aquacal Heat Pump

  4. Back To Top    #4
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: How much lube to use ?

    I can't imagine that it is a pump o-ring or valve issue. Much more likely that it is between the skimmer and the pump or main drain and the pump. Can you isolate one or the other? Might help narrow it down.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  5. Back To Top    #5
    bobodaclown's Avatar
    Join Date
    Apr 2011
    Location
    Lakeland, FL
    Posts
    2,351

    Lube enough to get the job done no more/no less.

    You can use running water (steady stream/not full blown jet), over the fittings/connections to help isolate the leak, or shaving cream, foaming/not gel.
    Run water/or place shaving cream on fittings and such, keep an eye on the basket and watch for the air bubble to dissipate, go slowly.

    With the shaving cream you can watch it get sucked into the leak.
    17K Kidney Shaped Pool Concrete (Diamond Bright) Pool, 3/4 hp 2 speed 115V Sta-rite Duraglas PEA5D-180L/P2R5D-181L (Impeller C105-92PS Diffuser C1-216P), 1.5 piping, Pentair CC100 Filter , Heat Siphon 100K BTU Heat Pump Pool Heater, Flow meter Blue White Flowmeter Model No. F-30150P, Hayward Astrolight SP0581N, SWCG CalimarTitanium Edition TE45 , Dolphin Nautilus Plus with CleverClean, Lakeland Florida

  6. Back To Top    #6
    n240sxguy's Avatar
    Join Date
    May 2014
    Location
    Benton, KY
    Posts
    1,800

    Re: How much lube to use ?

    Also check the threaded Union that ties into the suction of the pump.


    30K gallon IG vinyl. 1.5HP 2-speed Waterway Mustang pump. 600 lb sand filter. Polaris 280. Circupool SI-60+. TF-100

  7. Back To Top    #7

    Join Date
    Sep 2013
    Location
    Dallas-Ft. Worth Metroplex, TX
    Posts
    810

    Re: How much lube to use ?

    Quote Originally Posted by pooldv View Post
    I can't imagine that it is a pump o-ring or valve issue. Much more likely that it is between the skimmer and the pump or main drain and the pump. Can you isolate one or the other? Might help narrow it down.
    Makes no difference whether it's set for main drain or one or the other skimmer, I still get air and turbulence. I'll have to try the shaving cream.
    14K Freeform Gunite w/60% Blue Quartz plaster, Quad DE filter, Intelliflo VS Pump + Booster for Cleaner, Aquacal Heat Pump

  8. Back To Top    #8
    dumbcluck's Avatar
    Join Date
    Aug 2013
    Location
    long beach
    Posts
    670

    Re: How much lube to use ?

    how much air? pictures?
    -Jimbo- My pool was full of dirt and trees. Now it's full of water and children!
    20k gallon inground pool, 18" raised spa 7' round, 8 jets, 3" spa plumbing. Pentair intelliflo 3hp vsp, Easy touch 4 w/ ic 40, CCP 420 cartridge filter, Raypak 407a w/ cupro nickel, Screen logic 2, Pentair intelliph, spa side remote, Pentair 5g color lights pool and spa, TF-100 test kit with speed stir and Dolphin Oasis Z5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •