Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Communications on Aqualink System wonky

  1. Back To Top    #1

    Join Date
    Aug 2010
    Austin, TX

    Communications on Aqualink System wonky

    This is strange to describe, so bear with with me.

    About 4 months ago, something happened to my RS12 system, such that the second power center stopped communicating with the main power center. I cycled the power, checked connections, and it's back up and both power centers appear to be communicating without interruption for the last few months - but now my Touchlink (hardwired) drops communication after about a day. If I cycle the power it comes back for about a day. Also, the iaqualink controller drops connection with the RS unit occasionally, but recovers without cycling the power. I even rewired the touchlink. Everything seems to work, even though the touchlink will not reconnect on its own without cycling power. There are no errors shown on the iAqualink when I look at "help".

    There are a few things on the RS485 bus: Touchlink, PDA (add-on), iAqualink, intelliflo pump, Chemlink, LZi heater, and second power center. There is also a power surge protection circuit installed on both low voltage and high voltage circuits (the Jandy kit).

    I'm thinking that a) the main power center communications driver has become flakey, or b) the touchlink is damaged.

    If someone has been through this before or has some ideas, I'm all ears and would appreciate the help.

    I do have another question, maybe easier to answer. I would like to try a another (new/used) power center....they don't seem to be that expensive on ebay - but I'm not sure exactly what I need. I get the impression that an RS12 is really an RS8 plus an auxiliary power center, and that all that separates an RS8 from an RS12 is the CPU. Is it the case that any RS8 will work when paired up with the right CPU? Does it matter if it's a PDA unit (mine is not, it came with a onetouch)?

    1000x thanks for help!
    38K Gallons IG, Intelliflow VS-SVRS, 30GPM 24/7, 72sqft DE Filter, Spectralight UV, Jandy C1900 driving Liquid Chlorine and Acid (toys, I know..), Jandy LXi gas heater, Aquacal SQ175 Heatpump, Riverflow Competition swimmer, Jandy automation, Touch and iAqualink, Pebblesheen | The Build

  2. Back To Top    #2
    bobodaclown's Avatar
    Join Date
    Apr 2011
    Lakeland, FL

    Re: Communications on Aqualink System wonky

    Here's the manual.

    Hopefully there's some info in it that may help.
    17K Kidney Shaped Pool Concrete (Diamond Bright) Pool, 3/4 hp 2 speed 115V Sta-rite Duraglas PEA5D-180L/P2R5D-181L (Impeller C105-92PS Diffuser C1-216P), 1.5 piping, Pentair CC100 Filter , Heat Siphon 100K BTU Heat Pump Pool Heater, Flow meter Blue White Flowmeter Model No. F-30150P, Hayward Astrolight SP0581N, SWCG CalimarTitanium Edition TE45 , Lakeland Florida

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts