Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: my gnrerator reads Hot

  1. Back To Top    #1

    Join Date
    Feb 2015

    my gnrerator reads Hot

    I have an aquarite generator and it is reading" hot" I have tried unplugging the salt cell and turning off the power to reset it but it does not help. I called one pool store and they told me my salt cell is ruined, the sensor inside is ruined they say...

    I took the salt cell off and rinsed it in water and muratic acid and it stopped flashing and ran normally for about 1 hour. My pool water is very cloudy because I added an algaecide and not I am at a loss about what to do.. It is a goldline t-15 but I have a very small pool and I see on the internet that my pool only being about 10,000 gallons I should be using a t-3 which is for smaller pools.

    can anyone help me with this?

    Thank you, Patricia

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Tucson, AZ

    Re: my gnrerator reads Hot

    Welcome to TFP!!!

    So what happened after the hour?
    How old is the SWG system?

    There is nothing wrong with having a larger SWG cell, in fact we recommend it as it allows you to run the pump and SWG less and the SWG should last longer.

    BTW, we hardly ever recommend using algaecides ... If you get cloudy water or algae, you need chlorine and you need to follow the ShockLevelAndMAINTAIN Process which is done without the SWG.

    Since the SWG is not currently working, you should be using bleach to maintain adequate FC levels.

    Please add your location (City, State or City, Country) to your profile and pool details to your signature as described HERE as it will help us help you.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3

    Re: my gnrerator reads Hot

    Try turning the switch to off for five minutes. Turn the dial to 50 %. Then switch to auto. After 1 minute, scroll through the diagnostics and report what they say.

    Do you have a heater?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts