Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Pentair MasterTemp 250 Nat. Gas doesn't turn on after cycle ends

  1. Back To Top    #1
    AeroAero's Avatar
    Join Date
    Jan 2015
    Location
    Shrewsbury, PA
    Posts
    20

    Pentair MasterTemp 250 Nat. Gas doesn't turn on after cycle ends

    Pentair MasterTemp 250 Nat. Gas

    Unit is 6 months old (old unit lasted 2 years, cupro-nickel failed)
    Had to replace igniter within 2 weeks of purchase
    Water-flow is 68-70 GPM
    No warranty option (direct replacement of old unit by self/not prof. installed)

    Hi all,
    This unit is used at a hotel and runs 24/7. It heats up to 85 just fine. When it comes time to turn back on, unit usually throws the service heater light. Unit will not come on until turned off and back on.

    Manual (lots of help there) says I need a new control board. I swapped out the control board from the old unit. Same scenario, sometimes it works and sometimes it doesn't.

    Thought maybe the diverter valve on the filter was drawing air since it was leaking. Just replaced that and no change.

    Thank you for any suggestions, as I am just muddled at this point.

  2. Back To Top    #2

    In the Industry

    Join Date
    Mar 2011
    Posts
    441

    Re: Pentair MasterTemp 250 Nat. Gas doesn't turn on after cycle ends

    If you look at the back of the board do you see any of the service lights lit?
    20X40 30,000 gallon gunite pool

  3. Back To Top    #3

    In the Industry

    Join Date
    Jan 2011
    Posts
    153

    Re: Pentair MasterTemp 250 Nat. Gas doesn't turn on after cycle ends

    Sounds like a bad thermal regulator.

  4. Back To Top    #4
    AeroAero's Avatar
    Join Date
    Jan 2015
    Location
    Shrewsbury, PA
    Posts
    20

    Re: Pentair MasterTemp 250 Nat. Gas doesn't turn on after cycle ends

    No service lights on

  5. Back To Top    #5

    Join Date
    Dec 2016
    Location
    Amarillo, Texas
    Posts
    2

    Re: Pentair MasterTemp 250 Nat. Gas doesn't turn on after cycle ends

    I know this is an old thread, but I have an identical issue now. Heater brings water to selected temp, but does not come back on as temp drops, goes through start up sequence 3 times then service heater light comes on, no fail lights/codes. It lights when I shut power off and bring it back on. Seems like now I have a manual heater What ended up being the issue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •