Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Jet pump stopped wokring

  1. Back To Top    #1

    Join Date
    Apr 2014
    Location
    Canada
    Posts
    18

    Jet pump stopped wokring

    Hi,

    I have a Pacific Hot tub with Balboa panel and Aber top side panel. Today the jet pump stopped working as I may have overfilled yesterday. I add some water to raise the level and forgot all about it.. Today the jet pumps don't turn on if in filtration cycle or by pushing the button on the top side panel. There is voltage in the main panel as I have checked. Glass fuse looks good and other fuse has confirmed continuity. When I reset the breaker I cannot hear the relays switching which I have always been able to hear before. The jet pump was running in filtration cycle when I over filled it. Is the this a result of a shorted topside panel?

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Jet pump stopped wokring

    I would suspect a stuck relay, though it could be any of several things. Do you feel comfortable checking some voltages with a multi-meter? If so you could narrow it down fairly quickly.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Apr 2014
    Location
    Canada
    Posts
    18

    Re: Jet pump stopped wokring

    Very comfortable working with a multimeter. Could I just spray electrical cleaner on the relay? I have some and some other cleaners on hand.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •