Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 11 of 11

Thread: Why am I getting alarm notifications on SWG?

  1. Back To Top    #1
    We_Like_It_Hot's Avatar
    Join Date
    Jan 2014
    Location
    Las Vegas
    Posts
    33

    Why am I getting alarm notifications on SWG?

    I have removed my IC40 SWG for the winter and I also reconfigured Screen Logic so the SWG is not connected,
    but I知 bewildered as to why I知 receiving Pentair Alarm Notifications in my email after doing this.

    Has anyone else had this problem?

    Here are the errors I知 receiving in emails:
    Alarm Details:
    Chlorinator: Low Flow Error - Check Chlorinator flow switch for blockage. If running IntelliFlo pump, you may need
    to increase the flow rate.

    Chlorinator: Cold Water Cutoff - Chlorine feed is shut off due to cold water
    temperature.

    Chlorinator: Communication Lost - Comlink to the chlorinator has failed.
    Shotcrete 16'x25' rectangular with a half in 7' round spa raised 18" negative edge spillover, med. gray plaster. 9K gal. 3' sheer descent, 8'x12' wet deck.
    All equipment Pentair. 420 C&C, 400K MasterTemp, WhisperFlo 1hp, IntelliFlo, WhisperFlo 2hp, IC40 Intellichlor, EasyTouch Wireless ScreenLogic2 Interface, 3ea. GloBrite LED's.

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Why am I getting alarm notifications on SWG?

    You have ScreenLogic2, which is presumably configured to expect to see an IC40. Since the IC40 is not responding to it's requests, it is sending error messages. Nominally, it should only send the communications lost message. There others are excessive, but not exactly surprising (the IC40 is used to measure water temperature and flow).
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3
    We_Like_It_Hot's Avatar
    Join Date
    Jan 2014
    Location
    Las Vegas
    Posts
    33

    Re: Why am I getting alarm notifications on SWG?

    Jason, you’re saying “presumably”?
    I have reconfigured the ScreenLogic as I first mentioned and the main panel displays: (IntelliChlr, Enable: No)
    Also, I was not receiving any alarm notices prior to the initial connection of the SWG. Just seems like it shouldn't be sending
    any SWG notices when configured this way. I also called Pentair, they had no answer either.
    Shotcrete 16'x25' rectangular with a half in 7' round spa raised 18" negative edge spillover, med. gray plaster. 9K gal. 3' sheer descent, 8'x12' wet deck.
    All equipment Pentair. 420 C&C, 400K MasterTemp, WhisperFlo 1hp, IntelliFlo, WhisperFlo 2hp, IC40 Intellichlor, EasyTouch Wireless ScreenLogic2 Interface, 3ea. GloBrite LED's.

  4. Back To Top    #4
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Why am I getting alarm notifications on SWG?

    All of those error messages are IC40 related, so it makes sense that ScreenLogic2 thinks there is an IC-40 in the system. For that matter, it shouldn't offer you the option to enable/disable the SWG unless it thinks there is one present. I wonder if there is some other procedure to make it understand that there is no longer an IC40? Presumably there is, but I have no idea what it might be.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  5. Back To Top    #5
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Why am I getting alarm notifications on SWG?

    This is one of those questions that is about a specific piece of automation that very few members have any experience with, so it is hard to get an answer about a very specific aspect of that very specific piece of equipment. Jason does not have one, thus the need to make educated assumptions.

    You could soon be the expert with hands-on experience and answer everyone else's questions
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  6. Back To Top    #6
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: Why am I getting alarm notifications on SWG?

    My suspicion is that you might need to reboot the system for the changes to take effect. But that's just a gut feeling. I have no firsthand experience. I'm a jug-dumper.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  7. Back To Top    #7
    We_Like_It_Hot's Avatar
    Join Date
    Jan 2014
    Location
    Las Vegas
    Posts
    33

    Re: Why am I getting alarm notifications on SWG?

    Much appreciated comments fellow members and thank you all for your thoughts.

    Richard, you might have solved it for me. I didn't run across anything that directly mentioned how to reboot the ScreenLogic
    system in the manual, although it’s probably there and I just missed it. What I did do was disconnect power to my ScreenLogic
    Interface, then plugged it back in after a couple minutes. I know it’s only been 24 hours, but I have yet to receive an email
    alarm notice. I’m keeping my fingers crossed that solved the issue.

    jblizzle, your humor on me being an expert was a chuckle. If I can help anyone with my experiences with ScreenLogic,
    I will surely try my best.
    Shotcrete 16'x25' rectangular with a half in 7' round spa raised 18" negative edge spillover, med. gray plaster. 9K gal. 3' sheer descent, 8'x12' wet deck.
    All equipment Pentair. 420 C&C, 400K MasterTemp, WhisperFlo 1hp, IntelliFlo, WhisperFlo 2hp, IC40 Intellichlor, EasyTouch Wireless ScreenLogic2 Interface, 3ea. GloBrite LED's.

  8. Back To Top    #8
    We_Like_It_Hot's Avatar
    Join Date
    Jan 2014
    Location
    Las Vegas
    Posts
    33

    Re: Why am I getting alarm notifications on SWG?

    Well, 5 days later and not one alarm notice. I would say, issue solve!

    Thanks again Richard for your suggestion.

    Happy Holidays to all!
    Shotcrete 16'x25' rectangular with a half in 7' round spa raised 18" negative edge spillover, med. gray plaster. 9K gal. 3' sheer descent, 8'x12' wet deck.
    All equipment Pentair. 420 C&C, 400K MasterTemp, WhisperFlo 1hp, IntelliFlo, WhisperFlo 2hp, IC40 Intellichlor, EasyTouch Wireless ScreenLogic2 Interface, 3ea. GloBrite LED's.

  9. Back To Top    #9
    Mod Squad JVTrain's Avatar
    Join Date
    Feb 2014
    Location
    Central Minnesota
    Posts
    5,079

    Re: Why am I getting alarm notifications on SWG?

    First step in hardware, software, instrumentation... any thing with a chip in it trouble shooting: Did you restart it?

    Glad it's working!
    Joel - TFP Moderator - Minnesota - **Become a TFP Supporter!** Helpful Links: ABCs of Pool Water Chemistry - SLAM Procedure - Chlorine/CYA Chart
    40x20 Pool: 32K Gallons * Vinyl * Bleach Chlorination * Hayward S270T Sand Filter * Pentair SuperFlo 1 HP * Teledyne/Laars Heater * AquaVac Tigershark * TF-100 w/ SpeedStir
    Isolated Spa - 345 Gallons

  10. Back To Top    #10
    We_Like_It_Hot's Avatar
    Join Date
    Jan 2014
    Location
    Las Vegas
    Posts
    33

    Re: Why am I getting alarm notifications on SWG?

    JVTrain,
    If disconnecting power to my ScreenLogic Interface is called restart, then yes, I restarted it.

    Unfortunately, I'm not getting a warm fuzzy feel now, since reporting this issue to Pentair the tech
    didn't suggest a restart/reboot. This is going to be the first thing I do the next time I have any
    issues with the system from now on.
    Shotcrete 16'x25' rectangular with a half in 7' round spa raised 18" negative edge spillover, med. gray plaster. 9K gal. 3' sheer descent, 8'x12' wet deck.
    All equipment Pentair. 420 C&C, 400K MasterTemp, WhisperFlo 1hp, IntelliFlo, WhisperFlo 2hp, IC40 Intellichlor, EasyTouch Wireless ScreenLogic2 Interface, 3ea. GloBrite LED's.

  11. Back To Top    #11
    Mod Squad JVTrain's Avatar
    Join Date
    Feb 2014
    Location
    Central Minnesota
    Posts
    5,079

    Re: Why am I getting alarm notifications on SWG?

    Any type of restart can straighten many problems out on its own, if the issue is simply a firmware or software issue that needs to be reconfigured by a restart.

    A soft restart of a device would be restarting it using a software/firmware command or other input to restart without completely powering down. A hard restart is when you shut the device down with software/firmware commands (if possible or necessary) and remove all power from the device, then power on again. Start with a soft restart, if available, then try a hard restart if the soft restart doesn't solve the problem.

    Whenever you call for technical support on a computer, modem, router, instrument, etc. this is one of the first things on the list they will have you try unless the issue has presented itself in a clearly defined way, where another solution is evident.
    Joel - TFP Moderator - Minnesota - **Become a TFP Supporter!** Helpful Links: ABCs of Pool Water Chemistry - SLAM Procedure - Chlorine/CYA Chart
    40x20 Pool: 32K Gallons * Vinyl * Bleach Chlorination * Hayward S270T Sand Filter * Pentair SuperFlo 1 HP * Teledyne/Laars Heater * AquaVac Tigershark * TF-100 w/ SpeedStir
    Isolated Spa - 345 Gallons

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •