Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Sundance Marin 850 troubleshooting

  1. Back To Top    #1
    webbedtoes's Avatar
    Join Date
    Nov 2014
    Location
    Moses Lake,WA
    Posts
    12

    Sundance Marin 850 troubleshooting

    I just brought home a "free" hot tub this week after driving 200+ miles round trip. I'm an Industrial machinery electrician by trade so I should be able to fix this one. P.O. said it was displaying fault code for Over Temp but water felt fine so I'm guessing bad temperature sensor. It still had some water in piping when I loaded and hauled so hopefully no cracked pipes as we've been below freezing for weeks.

    13x27 Splash Pool A.G., Sundance Marin 850 spa
    13x27 Splash Pool AG (10k gal?)
    04 Sundance Marin 850 Spa

  2. Back To Top    #2
    webbedtoes's Avatar
    Join Date
    Nov 2014
    Location
    Moses Lake,WA
    Posts
    12

    Re: Sundance Marin 850 troubleshooting

    I left a space heater in it overnight set to about 70F and it's nice inside but still can't get the drain valve open. I suspect it's iced up at the valve. The manual says to screw on a regular garden hose and pull on the fitting to open the valve. I'll try again tomorrow. Is there a way to check the water's out with a wet dry vac instead?

  3. Back To Top    #3
    webbedtoes's Avatar
    Join Date
    Nov 2014
    Location
    Moses Lake,WA
    Posts
    12

    test pics









    - - - Updated - - -

    yup, that works!
    13x27 Splash Pool AG (10k gal?)
    04 Sundance Marin 850 Spa

  4. Back To Top    #4
    webbedtoes's Avatar
    Join Date
    Nov 2014
    Location
    Moses Lake,WA
    Posts
    12

    Re: Spa won't heat up!

    I found some very good how to videos on Youtube today. Evidently made by Sundance, among the topics covered is replacing the heater and replacing the sensors.
    13x27 Splash Pool AG (10k gal?)
    04 Sundance Marin 850 Spa

  5. Back To Top    #5
    webbedtoes's Avatar
    Join Date
    Nov 2014
    Location
    Moses Lake,WA
    Posts
    12

    Re: Sundance Marin 850 troubleshooting

    Finally got it hooked up and powered up for the first time today. Pumps all work but no heat. Faulty temp sensor and a melted heater assembly cover. Cracks in heater cover so repair or replace is the question. I think I can repair it, but should I? The cheapest replacement online is $162 for the whole unit.
    13x27 Splash Pool AG (10k gal?)
    04 Sundance Marin 850 Spa

  6. Back To Top    #6
    webbedtoes's Avatar
    Join Date
    Nov 2014
    Location
    Moses Lake,WA
    Posts
    12

    Re: Sundance Marin 850 troubleshooting

    Finally got the cash together for the heater, main sensor and replaced the circuit board and ozinator too. Cost me around $750 total. I was worried the updated board might have hickups with the old controls etc. All worked without a hitch. Just in time for fall.

    13x27 Splash Pool AG (10k gal?)
    04 Sundance Marin 850 Spa

  7. Back To Top    #7
    webbedtoes's Avatar
    Join Date
    Nov 2014
    Location
    Moses Lake,WA
    Posts
    12

    Re: Sundance Marin 850 troubleshooting

    No problems until now. Seems like a new ozinator should have lasted more than 8 months. A little bummed but $100 not as bad as it could be

    13x27 Splash Pool AG (10k gal?)
    04 Sundance Marin 850 Spa

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •