Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: StaRite Multiport selector valve issue

  1. Back To Top    #1

    Join Date
    Nov 2014
    Location
    Seffner, FL
    Posts
    15

    StaRite Multiport selector valve issue

    Hi, first time poster and pool owner. I was going to backwash my DE filter and switched the multiport selector while the pump was running. I didn't realize not to do that (to only change positions when the pump was off). Now water only comes out of the backwash hose no matter what position I put the selector on. What can I do?? Do I have to replace the valve or can it possibly be repaired? Thanks in advance.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: StaRite Multiport selector valve issue

    You most likely dislodged the spider gasket. You can take the valve apart and if it isn't torn you can put it back in place. Worse case, you'll have to replace the gasket.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    In the Industry
    Citizen's Avatar
    Join Date
    Oct 2014
    Location
    Orlando, FL
    Posts
    92

    Re: StaRite Multiport selector valve issue

    Quote Originally Posted by Bama Rambler View Post
    You most likely dislodged the spider gasket. You can take the valve apart and if it isn't torn you can put it back in place. Worse case, you'll have to replace the gasket.
    Bama is right and it is pretty straight forward to correct or replace a spider gasket. In case you are new I would suggest reading a guide or two to make sure you know what to do before you open the valve.

    Here is a guide and video I found about replacing a multiport valve's spider gasket: http://www.inyopools.com/HowToPage/h...ort_valve.aspx

  4. Back To Top    #4

    Join Date
    Nov 2014
    Location
    Seffner, FL
    Posts
    15

    Re: StaRite Multiport selector valve issue

    Bama Rambler and Citizen, thanks for the replies. That is exactly what happened. I purchased/replaced the gasket yesterday and waiting to test function today (after waiting for silicone adhesive to cure - I was advised to use a small amount to secure it to the plastic).

  5. Back To Top    #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: StaRite Multiport selector valve issue

    Glad it was an easy remedy.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  6. Back To Top    #6

    Join Date
    Nov 2014
    Location
    Seffner, FL
    Posts
    15

    Re: StaRite Multiport selector valve issue

    Me too, haha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •