Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Something on top of my sand filter is leaking...

  1. Back To Top    #1

    Join Date
    Jun 2013
    Location
    Dallas, TX
    Posts
    105

    Something on top of my sand filter is leaking...

    I had a problem earlier in the week where by heater's uniterm governor (thermostat) stuck and blew out. Ended up bypassing the heater to get the pool running. Afterwards, I've noticed the top of my sand filter is leaking.

    Pics: http://imgur.com/a/pxmdt

    At first I thought it was the black cap at the top of the filter, but this morning I'm seeing drops of water under the pressure release on top of that (you can see a drop in the picture, as well as water leaking down under the black top cap). That leads me to believe the release valve could be the issue.

    Is my correct course of action to replace the whole release valve piece up top or ?
    35k gal, sand, IG, diamond brite, Hayward Goldline T-CELL-15 Turbo SWG, Aquarite, Compool Lx3600

  2. Back To Top    #2
    Smykowski's Avatar
    Join Date
    Sep 2011
    Location
    Gurnee, IL (North Suburban Chi-town)
    Posts
    3,065

    Re: Something on top of my sand filter is leaking...

    I have no knowledge or experience with that type of filter, but those pieces all being distinctly different, I would guess that there's either an o-ring or threads (needing teflon tape or dope) to seal the joints. Can you find a parts explosion to see if there's any guidance there?
    33' round, 23,000 gal AG vinyl , 1HP 2spd PowerFlo Matrix downsized with 3/4HP impeller (X2), Hayward S180T 150# sand filter (X2), Hayward H250 NG heater Pool Store year 1 - $850 for 2 months; Pool Store year 2 - $440 for 2 months, TFPC year 1 - $170 for 4 months; TFPC year 2 - $95 for 4.5 months
    The most important article on this site - The ABCs of Pool Water Chemistry

  3. Back To Top    #3

    Join Date
    Jun 2013
    Location
    Dallas, TX
    Posts
    105

    Re: Something on top of my sand filter is leaking...

    Quote Originally Posted by Smykowski View Post
    I have no knowledge or experience with that type of filter, but those pieces all being distinctly different, I would guess that there's either an o-ring or threads (needing teflon tape or dope) to seal the joints. Can you find a parts explosion to see if there's any guidance there?
    Good call. I'll see if I can find a model number and look it up.
    35k gal, sand, IG, diamond brite, Hayward Goldline T-CELL-15 Turbo SWG, Aquarite, Compool Lx3600

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •