Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Jandy iAquaLink Upgrade, 2-Wire Heater Connection

  1. Back To Top    #1

    Jandy iAquaLink Upgrade, 2-Wire Heater Connection

    I've owned a Jandy AquaLink RS for about 8 years, since I first built my swim-spa.

    In all that time, I never had an issue with my heat pump (AquaCal TT120, a digital thermostat heatpump that supports 2-wire remote triggering). I used the simple 2-wire connection between the Jandy and heater (often referred to as the "Fireman's Switch").

    For anyone stumbling on this thread in the future, the 2-wire connection is a simple way for the Jandy to enable/disable the heater. The Jandy terminals #1 and #2 (on the top green terminal bar) are connected to terminals on the heater. Typically you must break a circuit on the heater as well (cut a small wire) and configure the heater using the digital keypad, so that it knows to allow the Jandy control, rather than its own thermostat.

    That configuration has always worked for me. Until I caught the "shiny new things" disease.

    Over a year ago I purchased an iAquaLink network-controllable controller to upgrade my original AquaLink RS. The CPU is "Revision R" (newer 50-pin style, requiring the new bezel replacement). All connections to the equipment are essentially the same, it's a very easy install.

    The network control part works fine with the standard Jandy relay-switches (1-8). However, the auxiliary features don't seem to work on the device:

    1) It will no longer turn the heater on/off.
    2) It no longer recognizes the Jandy Salt Chlorinator.

    The only thing that changed is the Aqualink Bezel/CPU board, nothing else. All wiring remains the same, as do all heater configurations. The Jandy has been re-configured to enable all related options.

    Originally I worked around the heater problem. I disable the Jandy-mode, and I manually adjusted the temp when I needed to use it.

    One week ago, the heater touchpad seems to have stopped being responsive and I'm forced to deal with this iAquaLink problem.

    Side Note:
    I called Jandy about the problem when I first installed over a year ago. The Jandy support rep logged-in remotely and said he didn't see anything wrong, but didn't know how to troubleshoot further. He said they'd call me back. When I didn't receive a reply, I tried calling Jandy three times more without any reply.

    Without support from Jandy, my next step is to test the heat-pump to eliminate the chance that it is bad. My assumption is that when the Jandy AquaLink turns the heatpump ON by completing the circuit; it turns it OFF by breaking the circuit (disconnecting). If that assumption is correct, and all pumps/water-pressure flowing through the heat-pump are correct, then opening/closing that circuit should enable the heat-pump, correct?

    One last question.. On the separate issue of the Jandy Salt Chlorinator.

    I read a post here on TFP about some of these new Jandy revisions (I believe it was "R") that have a problem with the Jandy Salt Chlorinator. Is there some way I can get Jandy to re-send me the upgraded firmware to fix this bug? Being that I'm using the AquaLink with their own Chlorinator, it seems they should offer some sort of fix; however, I have had no luck getting a call back on the original issue, much less any sort of refund/upgrade.

    Thank you in advance for any ideas!

  2. Back To Top    #2

    In the Industry
    malcolmb5325's Avatar
    Join Date
    Sep 2009
    Sydney, Australia

    Re: Jandy iAquaLink Upgrade, 2-Wire Heater Connection

    i have in the past cut the 1# & 2# wires in series with the flow switch of the heater. Leave the Heater on but it will not start unless the flow switch wire is closed via the Aqualink. Are you saying that the "Heater" doesn't show up on the One Touch panel and the iAqualink device? (phone, ipad etc.). Have you set the dip switches up on the lefthand side of the main pcb?
    16,000lts Fibreglass, Magna Mineral Pool Water
    Jandy CV340 Cartridge filter, Zodiac TRi SWC, Z4 iAqualink, Jandy Laminar Jets, Solar Heating, Spa Jets with Jandy 1.5hp Epump operating everything.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts