Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Hayward H250 heater not staying on

  1. Back To Top    #1
    camillian's Avatar
    Join Date
    Jul 2009
    Location
    Toronto, Canada
    Posts
    17

    Hayward H250 heater not staying on

    hello

    when called upon my heater turns on and runs for about 3 seconds and shuts off, I then try and restart it again and again and it shuts off, I will eventually get it going for about 5 or 6 seconds then again it shuts off, eventually it will stay on and work great until we no longer call for heat. the yellow service light goes on and off once every 10 seconds.

    can anyone help me, the heater is 7 years old and otherwise runs great.

    Thank you
    I.G. Vinyl 17,000 gl. 16 x 32 cresent, 11' steps, spillover spa, natural rock waterfall, saltwater, Aqualogic P4 system w/aquapod and spa side remote, Aqua rite T-15 salt, Hayward H250, Hayward cartridge filter, 2 x 1.5hp Hayward superpump(pool & spa), 1 x 1hp superpump(waterfall)

  2. Back To Top    #2

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,437

    Re: Hayward H250 heater not staying on

    Is this heater electronic with a digital display or does it have dials on it?
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  3. Back To Top    #3
    camillian's Avatar
    Join Date
    Jul 2009
    Location
    Toronto, Canada
    Posts
    17

    Re: Hayward H250 heater not staying on

    Quote Originally Posted by ps0303 View Post
    Is this heater electronic with a digital display or does it have dials on it?
    it is electronic with digital display
    I.G. Vinyl 17,000 gl. 16 x 32 cresent, 11' steps, spillover spa, natural rock waterfall, saltwater, Aqualogic P4 system w/aquapod and spa side remote, Aqua rite T-15 salt, Hayward H250, Hayward cartridge filter, 2 x 1.5hp Hayward superpump(pool & spa), 1 x 1hp superpump(waterfall)

  4. Back To Top    #4

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,437

    Re: Hayward H250 heater not staying on

    Are you getting an IF error on the display? An IF code would indicate a bad ignitor which is also the flame sensor.

    When you say the service light comes on, is this while the unit is lit and heating? If the service light comes on while heating and no code is showing on the display, this would indicate that the board behind the keypad is bad and needs to be replaced.
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  5. Back To Top    #5
    camillian's Avatar
    Join Date
    Jul 2009
    Location
    Toronto, Canada
    Posts
    17

    Re: Hayward H250 heater not staying on

    It is hooked up to a P4 system so the heater display always shows BP(bypass), when I have a lighting issue because of the wind for example it will show IF(ignition Failure) but now there is no code, just the yellow service light flashing every 10 seconds or so, when it finally starts running the green heat light will stay on and the yellow service light will stop flashing. Myself I thought maybe its a gas flow problem or another part that has worn in the 7 years I've had it as eventually it will run, but then when it reaches the desired temperature and it is off for a few hours I go through this problem all over again.
    I.G. Vinyl 17,000 gl. 16 x 32 cresent, 11' steps, spillover spa, natural rock waterfall, saltwater, Aqualogic P4 system w/aquapod and spa side remote, Aqua rite T-15 salt, Hayward H250, Hayward cartridge filter, 2 x 1.5hp Hayward superpump(pool & spa), 1 x 1hp superpump(waterfall)

  6. Back To Top    #6
    camillian's Avatar
    Join Date
    Jul 2009
    Location
    Toronto, Canada
    Posts
    17

    Re: Hayward H250 heater not staying on

    Now i'm noticing the yellow service light on the heater display is flashing twice every 10 seconds or so,

    I think it has to be some part on the heater that is worn and is not allowing the heater to start up consistently
    I.G. Vinyl 17,000 gl. 16 x 32 cresent, 11' steps, spillover spa, natural rock waterfall, saltwater, Aqualogic P4 system w/aquapod and spa side remote, Aqua rite T-15 salt, Hayward H250, Hayward cartridge filter, 2 x 1.5hp Hayward superpump(pool & spa), 1 x 1hp superpump(waterfall)

  7. Back To Top    #7

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,437

    Re: Hayward H250 heater not staying on

    The heater is not smart enough to know anything about the gas or it's pressure. I would have to say what you have is a bad control board. However, you can't buy just the board, you have to buy a entire new assembly unless you find one on ebay. Then you have to hope that it works.

    Error codes will always display regardless of it being in bypass mode.

    Here is what you need, http://www.parts4heating.com/Hayward...haxcpa1932.htm
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •