Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Jets not working after pump installed

  1. Back To Top    #1

    Join Date
    Aug 2014
    Location
    Spanaway/WA
    Posts
    5

    Jets not working after pump installed

    I just had a new pump installed in my hot tub. Tub was drained to allow the pump to be removed and replaced. I have water coming out of some of the jets and not out of the others.
    Would I still go to the unions to bleed the air from the system? There is a vent on the pump which is supposed to allow air to escape.
    Any information will be appreciated.
    Thanks,
    Bob

  2. Back To Top    #2
    Mod Squad JVTrain's Avatar
    Join Date
    Feb 2014
    Location
    Central Minnesota
    Posts
    5,079

    Re: Jets not working after pump installed

    Were they all working before the new pump? Are all the jets open?

    Many tubs have jets with outer rings that can be twisted clockwise to close them individually. Check the ones that aren't flowing and try to twist the outer rings counter-clockwise.
    Joel - TFP Moderator - Minnesota - **Become a TFP Supporter!** Helpful Links: ABCs of Pool Water Chemistry - SLAM Procedure - Chlorine/CYA Chart
    40x20 Pool: 32K Gallons * Vinyl * Bleach Chlorination * Hayward S270T Sand Filter * Pentair SuperFlo 1 HP * Teledyne/Laars Heater * AquaVac Tigershark * TF-100 w/ SpeedStir
    Isolated Spa - 345 Gallons

  3. Back To Top    #3

    Join Date
    Aug 2014
    Location
    Spanaway/WA
    Posts
    5

    Re: Jets not working after pump installed

    Hi,
    They were all working before the tub was drained and the new pump was installed.
    Now two sets don't work. I've twisted the the outer rings.

  4. Back To Top    #4
    mark-o's Avatar
    Join Date
    Jun 2014
    Location
    Bossier Louisiana
    Posts
    18

    Re: Jets not working after pump installed

    It the new pump the only pump? I have a 7 person Morgan spa and it has two pumps. One pump is a two speed and takes care of most of the seated jets and a single speed pump takes care of lounge jets and large circulating jet near bottom of spa. Maybe you have a second pump that was unplugged in the install of the new one?
    16 x 36 inground vinyl w/ covered steps. 9 1/2 ft deep end w/ diving board. 27,000 gal.
    PacFab Challenger 1 1/2 hp 2 speed pump, Pureflo 300 lb sand filter, Pentair chlorine feeder
    1 skimmer, 1 main drain, 3 return lines and NO LEAKS "knock on wood" LOL.

  5. Back To Top    #5

    Join Date
    Aug 2014
    Location
    Spanaway/WA
    Posts
    5

    Re: Jets not working after pump installed

    Hi,
    I wish it were that easy. I do have a second pump but it is currently doing what it was before the new pump was installed. It takes care of the lounge and some of the seated spa jets. The new two speed pump takes care of the jets on the right side of the spa and one down low jet at the bottom, so four sets of jets. The set of jets at the far back right and the set in the middle of the right side are working. The set in the corner closest to the pump and the down low jet are not working. I have a "Sweetwater Palermo" spa.

  6. Back To Top    #6
    TrevNJPool's Avatar
    Join Date
    Jul 2014
    Location
    atco/nj
    Posts
    142

    Re: Jets not working after pump installed

    I would call whoever installed the pump and make them fix it.
    40x18 Lazy L Rectangle
    29500gal IG w/ vinyl liner
    HAYWARD S244T 300lb sand filter
    Hayward Super Pump 1 1/2hp

  7. Back To Top    #7

    Join Date
    Aug 2014
    Location
    Spanaway/WA
    Posts
    5

    Re: Jets not working after pump installed

    I think that is what I am going to do.
    Thank you all for your comments.
    Bob

  8. Back To Top    #8

    Join Date
    Aug 2014
    Location
    Spanaway/WA
    Posts
    5

    Re: Jets not working after pump installed

    Hi,
    I had the company that installed the new pump come out to fix the problem. Mystery solved. It was a bad pump. It was also causing the circuit breaker to trip at the end.
    Again,
    Thanks for chiming in, in my hour of need.
    Bob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •