Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Filter problem/suggestion for new filter

  1. Back To Top    #1

    Join Date
    Apr 2014
    Location
    Ontario, Canada
    Posts
    49

    Filter problem/suggestion for new filter

    I've been having troubles finding a leak in my pool. In addition, I am having troubles with murky water returning to the pool after I vacuum and backwash. I think both problems are with my pool filter. The other day my filter started a small leak (not the original cause of the leak mentioned above, this was new) on the selector valve (to select filter, backwash, etc). so I took it apart, cleaned it, lubed it and put it back together. The leak at the selector valve then stopped. Yeh! Then, a day or two later and just by chance I noticed a small trickle of water was coming out my backwash hose. So, my thinking is this could be the original leakage problem. My guess is that the match up and seal of the diverter isn't solid, allowing some water to escape out the backwash hose....causing my original leak problem. Then it occurred to me this could be the same problem where there could be some seepage from the non-filtered water getting into the return...causing the occasional murky water in the return.
    So....I don't know how old this filter is but I know the diverter has been replace at least once (the previous owner left the old one behind), but, I'm sick of the problems which I think are being caused by the filter. Could someone recommend a sand filter based on my configuration? (Is more info than what is in the signature needed?)

    Thanks
    Tim
    18k IG vinyl pool, Jandy CV460 Cartridge filter, Hayward MaxFlo Variable Speed 1.5hp pump (SP2300VSP), Hayward Aqua Rite Salt Generator with 25K Gal Cell, Teledyne Laars Series One heater, Blood, sweat and tears manual cleaner (trying to decide what to get to replace me), no automation.

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,200

    Re: Filter problem/suggestion for new filter

    When you had the selector valve apart did you check the condition of the spider gasket? It should be firmly attached at all points and not show signs of excessive wear to function correctly. A loose or worn out spider gasket will cause leaks.
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  3. Back To Top    #3

    Join Date
    Apr 2014
    Location
    Ontario, Canada
    Posts
    49

    Re: Filter problem/suggestion for new filter

    Thanks for the reply zea3. Although I didn't pay too much attention, I did run my finger along the spider gasket and didn't feel anything out of place. I think, but like I said, I didn't pay too much attention, the gasket is embedded in the valve as part of the manufacturing process so it doesn't look to be a replaceable part. I'll remove it today and take a better look.
    18k IG vinyl pool, Jandy CV460 Cartridge filter, Hayward MaxFlo Variable Speed 1.5hp pump (SP2300VSP), Hayward Aqua Rite Salt Generator with 25K Gal Cell, Teledyne Laars Series One heater, Blood, sweat and tears manual cleaner (trying to decide what to get to replace me), no automation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •