Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: What can I use for my AquaBot Turbo T Cleaner I Repaired

  1. Back To Top    #1

    Join Date
    Aug 2014
    Location
    Lincoln Park, MI
    Posts
    2

    What can I use for my AquaBot Turbo T Cleaner I Repaired

    I have a AquaBot Turbo T Cleaner, yesterday the pool cleaner would not run, so today I tested my power supply, that was fine but right on the handle where the power cord attaches to the Aquabot(Handle) with 2 clamps,
    it had a bend in the cord from the clamps where the cable goes up to float. I took the clamps off then plugged it in, I straightened the kink out, pushed it together. it started working, let go and it stops.
    I then cut the kink out of the power cable, reattached the wires, put some electrical tape around it, turned it on and it RUNS now. I saved the outer rubber coating that goes over the actual wire.
    My question is: Does anyone know what I should or could use to apply over the connection that I spliced back together and put electrical tape around, that would be a waterproof sealant and I can use the outer rubber coating I saved over it or if I need to buy some other rubber to to go over it, along with some good Waterproof sealant or glue.

    Thanks You,
    zzzroc

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: What can I use for my AquaBot Turbo T Cleaner I Repaired

    Welcome to TFP!

    I would solder the connection and then put adhesive shrink tube over it.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3

    Join Date
    Aug 2014
    Location
    Lincoln Park, MI
    Posts
    2

    Re: What can I use for my AquaBot Turbo T Cleaner I Repaired

    Thanks, jblizzle

  4. Back To Top    #4

    Join Date
    Jun 2007
    Location
    Poughquag, NY
    Posts
    217

    Re: What can I use for my AquaBot Turbo T Cleaner I Repaired

    I had the same thing happen, my kink was just inside the unit though and the short had burned a small hole through the floating wire covering. I connected the wires using "water resistant" nuts, then covered everything with several layers of liquid electric tape (making sure to cover everything I could see), then I wrapped it all in some of the self sealing silicon tape. So far it seems to be working, going on close to a month of use after repair (3 to 4 times a week, plus some overnights just sitting in the pool).

    I didn't use heat shrink because I was afraid of damaging the wire cover and I've never really had good luck with it, I always seem to burn it. If you do use the shrink tube, I would still recommend getting the self sealing silicon and wrapping that over the shrink tube. The stuff is amazing and pretty cheap (around $5 a roll).

    I found the problem after buying a new Turbo T (which is now in storage) and a new motor for the old one (figured I would repair the old one and keep it as a backup). I should be set for Turbo Ts for quite a while...
    20 x 40 vinyl IG. SWG. Solar. Ikeric VS pump.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •