Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Pentair IntelliPH stopped working (Red LED)

  1. Back To Top    #1

    Join Date
    Aug 2010
    Jacksonville, FL

    Pentair IntelliPH stopped working (Red LED)

    I Can not get my IntelliPh to work. I have a red light on the display, one of the possible causes is "Cell communication link is down". I have an IntelliTouch i7+3 and IntelliChlor IC40 I am showing the salt level, chlorine output and temp on my ScreenLogic so I know that is working. On the IntelliPh display under "Cell Status" I see the Salt level but not the temp. My guess is that for some reason it is not receiving the temp so it will not dispense the acid, I have been told from someone that Pentair sent out to fix the problem that, Pentair said the temp is used in the IntelliPh and that is for future updates.

    What would cause this not to work? Simple set up, IntelliChlor to the IntelliPh, IntelliPh to the Power Center.

    Soon to be built: ~15,000 gallon in ground pool/spa Gunite with Marbletite Beach series finish, Pentair Intellitouch I7+3, Intellibrite LED lights, Sta Rite Intellipro VS 3050 pump, Star Rite PLM cartridge filter, IC40 SWG, Sta Rite Max E Therm 400K propane gas heater, Automatic water level

  2. Back To Top    #2

    Join Date
    Apr 2015
    St Petersburg

    Re: Pentair IntelliPH stopped working (Red LED)

    I have the same problem, what ended up fixing it?
    20k gallon inground plaster, intellichlor I40, Pentair heatpump, Pentair Whisper Flo.

  3. Back To Top    #3
    dumbcluck's Avatar
    Join Date
    Aug 2013
    long beach

    Re: Pentair IntelliPH stopped working (Red LED)

    Have you tried resetting?

  4. Back To Top    #4
    acgibson's Avatar
    Join Date
    Aug 2014
    Olney / IL

    Re: Pentair IntelliPH stopped working (Red LED)

    Same issue with Screen logic losing communication with SWG. My red light was on today when I fired it up for the season, and I had it manually feed a little acid and it "checked cell status" and the light turned green.

    As far as the communication on the SWG with Screen Logic I am waiting on a Pentair guy to come look. The Big panel will control the SWG and you can set whatever percentage you want and it works fine (at least on mine), but just not on the computer/iphone. Before I installed the IntellipH the screen logic worked flawlessly, so I may un hook it from SWG and just use pump once I see how much I need it in swim season.
    18,900gal Viking 16'x40' Fiberglass In-Ground Pool w/ Cover Pool Auto Cover.
    WhisperFlo WF-24; Clean & Clear RP 150 Cartridge Filter; UltraTemp Heat Pump; IntelliChlor IC40 w/ IntelliPh Acid Pump;
    Easytouch Panel w/Screen Logic. Kreepy Krauly 820 Robot.
    LaMotte WaterLink Mobile Spin Lab & TF100/K2006 w/ Speed Stir.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts