Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: de filter grits covered with algae

  1. Back To Top    #1

    de filter grits covered with algae

    i cleaned grids twice since Sunday, is this normal to have grits covered in algae? pool was closed green last year because of motor issues. backwashing seems to bring pressure back to normal but not for long. its a 53sqft filter i think i should be putting in 5lbs of de, but that seems to be clogging grits.
    Attached Images Attached Images
    32000 gal , gunite pool, de filter weber gensis and tiki bar

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Tucson, AZ

    Re: de filter grits covered with algae

    Looks like the filter is working correctly. A DE filter will clog very quickly when you have live algae in the pool which is quite a hassle.

    You need to follow the ShockLevelAndMAINTAIN Process to get it all killed so the filter can clean up the pool. If you can bypass the filter at the start of this process, then that will reduce the frequency of having to clean the filter.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts