Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Laars LX - Air Flo Switch error after installing new blower

  1. Back To Top    #1

    Join Date
    Jul 2014
    Location
    Toronto, Ontario, Canada
    Posts
    4

    Laars LX - Air Flo Switch error after installing new blower

    We have a Laars LX (Installed 2007) pool heater in southern Ontario. It is in use late May to mid Sept.
    This heater has largely been a disappointment. We've replaced the blower twice on it.
    This may be our last season as I can't abide its unreliability.

    Our replacement blower (installed 2011) failed this summer (it would hum, but would not turn) so we replaced it last week with a new blower.
    Upon installing the new blower, the heater went through its start-up sequence fine and we were again heating.
    This was with the top off and the front access panel removed (i.e I was checking to make sure everything was ok before wrapping up.)
    Upon closing up the heater (top back on, front panel back on) we again got the air flow switch error.

    I re-opened the heater (top off, front panel removed). Re-started it, and everything worked fine. We were heating.
    Again, upon closing it up, I got the air flow sw error.

    I've checked to be sure the Fan Pressure Switch hose is well connected at the fan and the switch and that it isn't being crimped when the cover goes back on.
    At this point I'm a bit stumped and would welcome any advice in case anyone has run across this one before.

    Pat

  2. Back To Top    #2

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,436

    Re: Laars LX - Air Flo Switch error after installing new blower

    Interesting issue. First, when a fan motor won't start, but spins freely when spun by hand, it's usually the run/start capacitor which is replaceable. So what happens with just the front door off, does it keep running?
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  3. Back To Top    #3

    Join Date
    Jul 2014
    Location
    Toronto, Ontario, Canada
    Posts
    4

    Re: Laars LX - Air Flo Switch error after installing new blower

    Hi Paul,

    Thanks for the response.
    With the top on, the bottom panel removed and the top panel slid down to expose the fenwal it ran for a good 40 minutes with no issue. I then shut the heater down.

    Here are a couple of other facts:
    The unit is installed outside.
    The vent grill on the heater top no longer bolts solidly to the flue vent inside the heater because a couple of the clips have fallen away.
    Could it be that this is resulting in a poor flue seal and therefore some of the hot exhaust is leaking into the heater interior and
    causing sensors/switches to overheat?
    In any event, I'm going to fix that just to resolve that from becoming another issue down the road.

    Pat

  4. Back To Top    #4

    Join Date
    Jul 2014
    Location
    Toronto, Ontario, Canada
    Posts
    4

    Re: Laars LX - Air Flo Switch error after installing new blower

    Well,

    I got some speed nuts and have firmly attached the vent grill to the heater top. That also pulled the vent flue up tight against the heater top, creating a good seal.
    I've now run the heater "all closed up" for 2 hours yesterday evening and all day today. No further problems.
    I'm suspecting that because the flue was a bit loose, some of the hot exhaust may have been leaking into the heater chamber and affecting the switches.
    That's all I can conclude since the only thing that has changed is that the flue's now on tight.
    I'm hoping the problem's solved. (1) Because I don't know what else to try (well...call in the pros) and (2) because this fix cost me $3.00 for the speed nuts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •