Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Pump leak at motor. High filter pressure

  1. Back To Top    #1

    Join Date
    Jul 2014
    Location
    Arlington, Texas
    Posts
    2

    Pump leak at motor. High filter pressure

    We have a consistent leak from our pump. It appears to be leaking at the motor/pump connection. A puddle develops under the pump once it starts up. We can't operate our pump for any period of time. The filter pressure rockets up past backwash levels when the pump runs for 10 minutes. I took the pump apart and inspected the mechanical seals. I didn't see any visible problems with the seals and put it back together. Still experienced the same problems. Trying to figure out where our leak is coming from and why our filter pressure is so high. I am assuming that air is getting into the system somehow and we have a bad seal somewhere. I have replaced the housing seal and replaced my filter grids.

    Hayward SPX3010X15AZ pump, Penatair FNS Plus DE filter. Approx 45,000 gallon pool

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,078

    Re: Pump leak at motor. High filter pressure

    Welcome to the forum. How high is the pressure? Not much advice can be offered when we have no idea what pressure you are talking about.

    The leak sounds like a shaft seal leak but it's hard to tell. What is your psi with the pump running?


    The water leak tells us that you do not have an air leak.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3
    Charlie_R's Avatar
    Join Date
    May 2013
    Location
    Mexico, MO
    Posts
    2,156

    Re: Pump leak at motor. High filter pressure

    Welcome!

    When was the last time you took your filter apart and did a thorough cleaning?
    15'x48" 4500 gallon Intex pool, buried 1.5 ft. Pac-Fab Dynamo 3/4 hp pump. Hayward S180T sand filter, bought used. Taylor K-2006 test kit. Rocket mass heater based wood fired pool heater.

  4. Back To Top    #4

    Join Date
    Jul 2014
    Location
    Arlington, Texas
    Posts
    2

    Re: Pump leak at motor. High filter pressure

    Quote Originally Posted by Charlie_R View Post
    Welcome!

    When was the last time you took your filter apart and did a thorough cleaning?
    Hello this is the wifey! Hubby has taken the entire filter system apart several times and cleaned it in the past week. OUr pool is pretty green so it gets dirty fast. When i was messing with it on Saturday, the pressure was going past the dial that said clean filter - I would guess about 50%. I will have him check in tonight. I am hoping someone has some ideas as to what else to check! He has taken the pump apart and put together several times and we still have water leaking. Thank you all!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •