Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: No lights on my Naturesoft SWG

  1. Back To Top    #1

    Join Date
    Apr 2013
    Location
    Southern California
    Posts
    27

    No lights on my Naturesoft SWG

    I have no lights at all including display . I checked for a fuse but saw none. What is the troubleshooting steps for this unit? Picture attached
    17000 gl. In-ground vinyl pool
    Naturesoft/aquarite SWG t-15 cell
    Vinyl liner measured and installed by me

  2. Back To Top    #2

    Join Date
    Apr 2013
    Location
    Southern California
    Posts
    27

    Re: No lights on my Naturesoft SWG

    Well after reading and more reading I did a search for my board number which is 066012b-1 and read about a similar problem with no display or lights. I didn't see a fuse inside the box and read about a glass fuse. But I knew that underneath the box there was no big old style glass fuse. So I checked for giggles and what do you know there was a fuse and it was glass but not the huge type I thought but a small tube like fuse which I checked and it was blown. I changed it and it now works perfect.
    But there were 2 types to choose from, a 20A 32Vdc and a 20A 32Vac. I just tried the Vdc and seems to be fine. Not sure if I need the other kind but if someone knows better please be kind and say so.
    17000 gl. In-ground vinyl pool
    Naturesoft/aquarite SWG t-15 cell
    Vinyl liner measured and installed by me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •