Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Help needed priming pump

  1. Back To Top    #1
    Hottrodd1968's Avatar
    Join Date
    Jun 2014
    Location
    Long Island... Suffolk County North Shore, NY
    Posts
    70

    Help needed priming pump

    Hi all... I have a hayward power Flo matrix pump and regenx d.e. Filter RG700. I filled my 15 x 30 oval pool almost two weeks ago, percolated the d.e. Filter, ran the pump with no problems. After a day or so, I hooked up an Intex SWG and added 280 lbs. of salt. The pump had primed with no problem. I've been building a wood deck around the pool, so the equipment needed to be moved, shut off, relocated again... And now I don't get the same prime in the pump as I did initially. Checked the o ring, lubed it, resealed it, regenerated my d.e. Filter a few times... No luck. I ended up taking out the d.e. If.ter, cleaning it, repriming... Thinking it could be from the dirt and saw dust flying around. Checked my hoses, no obstruction. I called Hayward and they tell me that it's okay to have a little pocket of air inside the pump basket housing, but when I initially used the pump, the water completely filled the housing. I don't have the same skimmer suction as I did, though I do have water coming out the return, with no bubbles. Any advice would be great. I have a bunch of dust and dirt sitting at the bottom of my pool, and don't have enough suction power to really vacuum it up. I'm sure I've left out a great deal of info, but if I could just get the pump to fully prime... That would be a great start. Any ideas??
    Cathy...15 x 30 x 54" Sharkline Echelon oval AG 12,600 gallons
    Hayward ReGenX grid element D.E. Filter RG70075XEH
    Hayward Power-Flo Matrix pump series 1.5 hp
    Intex Krystal Clear SWG system for up to 14,000 gallon pools
    TF-100 test kit & speed stir

  2. Back To Top    #2

    TFP Guide

    Kiss4aFrog's Avatar
    Join Date
    May 2013
    Location
    Hudson, WI
    Posts
    2,602

    Re: Help needed priming pump

    Posting some before and after photos of the install might help. At least some after shots in case something sticks out to someone.
    '70s IG Vinyl 32K gal, Lazy L, Hayward SuperPump 1.5hp 120V, S240 Sand Filter W/DE
    Solar Blanket, Well Water, Borax Added, TF-100 tester. ? too cold
    1979, 275gal Conway Emerald Spa P-100-2, ES-2 Spa Pack, bromine floater, indoor
    TF-100, Best test kit - TFTestkits.net
    Please help keep the lights on, become a TFP Supporter!

  3. Back To Top    #3
    Hottrodd1968's Avatar
    Join Date
    Jun 2014
    Location
    Long Island... Suffolk County North Shore, NY
    Posts
    70

    Re: Help needed priming pump

    I dint take any pics because nothing really changed in the setup. Just moved equipment keeping all connections as initial. I will take pics tomorrow. I attempted to vacuum again, and left the vacuum on the skimmer for a longer period of time... and that seemed to improve the suction once I removed it, but still have a little air inside the pump basket. I noticed when vacuuming up what looks like white chalky dust settled on the floor... that the return water would be somewhat cloudy as well. Any chance it could be the D.E.? This is the first time I'm using this type of filter... I thought the d.e. would stick to the cartridge and not return back to the pool. Not sure how to tell what this white stuff is. I've decided to let the pump and SWG run through the night and see what happens tomorrow. I have another Hayward pump and D.E. Filter that a friend gave me (used for their in ground pool with capacity larger than mine). Probably overkill because the filter looks massive (Pro Grid vertical) and the pump is a Super pump... but figured better a powerhouse for now rather than spending a good portion of my short N.Y. Summer fussing around with my current one. My pool literature states its a 14,700 gallon pool, but when i do the math... I come up with no more than 12,000 . Would the bigger filter and pump work for my above ground setup? Still trying to self teach all about pools. Too much to learn in a short period. Glad i have this forum to bounce things off of.
    Cathy...15 x 30 x 54" Sharkline Echelon oval AG 12,600 gallons
    Hayward ReGenX grid element D.E. Filter RG70075XEH
    Hayward Power-Flo Matrix pump series 1.5 hp
    Intex Krystal Clear SWG system for up to 14,000 gallon pools
    TF-100 test kit & speed stir

  4. Back To Top    #4

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,083

    Re: Help needed priming pump

    The psi gauge is critical for tracking down air leaks.

    What was your psi when things were working well? Did the psi go to zero when you turned it off?

    What is the psi now that things are not working well? Do you still go to zero when the pump is off.?

    A mechanical guru on the forum, Richard 320 says, (I have to paraphrase) "The first thing that breaks is the last thing you fixed!"
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •