Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Heat Problem - Display Blank

  1. Back To Top    #1

    Join Date
    Jul 2014
    Location
    Ottawa Ontario
    Posts
    49

    Heat Problem - Display Blank

    Hi there!

    I have a Haywood natural gas pool heater, H250FDN. I've being trying to diagnose a problem with the display as it is blank. The heater itself is functional and running but I would like to see what is actually going on!

    So far, I have checked the four fuses on the fuse board and all are good. I also checked the spade fuse on the main board; it is good too. Any suggestions as to what else to check? Any ideas as to what may be wrong?

    Thanks,

    P.S. I did a bit for searching before posting this. Seems most people got an error code. I have not seen one yet.

  2. Back To Top    #2

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,437

    Re: Heat Problem - Display Blank

    So the display is totally blank but the keys for turning it on/off work? If that is all, then you had a bad display board.

    http://www.parts4heating.com/Hayward...0059456600.htm
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •