Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pool Heater inlet valve problem

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    San Carlos, CA
    Posts
    2

    Pool Heater inlet valve problem

    Hi, I have an early 70's Anthony pool heater that has been giving me problems starting the past few years. It works fine for a few weeks after I backwash the filter, but any rise in pressure and it refuses to fire. I disconnected the inlet/outlet to see if I could clean the heat exchanger. When I did this, I turned on the pump and notice water was coming out equally strong from the inlet and outlet ports. Removed the cover of the inlet/outlet valve and it doesn't look right inside. See photos attached. It looks like the washer on the outlet side is in the wrong place, (maybe it came dislodged and ended up on the bottom of the valve box?). Has anyone seen this or know whether I can fix it or replace it?inletoutletvalve.jpginletoutletvalve1.jpg


    I know, it is time for a new filter, but I'd like to see if I can keep this alive for one more year until I remodel the pool.
    I replaced the pressure switch last year, which seemed to help.
    Thanks in advance for all comments.

  2. Back To Top    #2
    gtemkin's Avatar
    Join Date
    Jun 2008
    Location
    Seattle, WA
    Posts
    738

    Re: Pool Heater inlet valve problem

    Your right it's in the wrong place! I'm guessing the exhaust side should look just like the intake side except it's sitting horizontal instead of vertical. What material is the washer made out of? It should be stiff so I'm not sure how it could come off on it's own unless the hole in the center is terribly worn and would fit over the spring. The exhaust valve is basically an internal bypass valve but I think it should supplement an adjustable external bypass valve in your plumbing so it doesn't have to do the "heavy lifting" every time the pump is running. I'm not an expert on that so I'm sure more knowledgable folks will chime in.
    21K gal 16' x 40' in-ground pool built 1959, old school with Jacuzzi bronze pump, American Products 24" Sand Filter & Americana Multiport valve, Jandy Lite2 millivolt heater, Coverstar cover, and classic Kreepy Krauly.

  3. Back To Top    #3

    Join Date
    Jun 2014
    Location
    San Carlos, CA
    Posts
    2

    Re: Pool Heater inlet valve problem

    Yes, you are right, the hole in the center of the washer was worn, allowing it to ride over the spring. I couldn't find an identical washer, so I just stacked one with the right size inner diameter against it and everything is working fine. I checked that it will still open under pressure. I am wondering if someone makes a replacement that would fit in place of this assembly, but no luck so far. Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •