Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: remove lube or no?

  1. Back To Top    #1
    Chewbubba's Avatar
    Join Date
    Jun 2012
    Russellville, AR

    remove lube or no?

    I'm fixing to assemble my cartridge filter/pump from last year, and I remembered at the end of last year, I smeared Magic Lube on all the gaskets and rings and shoved them into a couple of ziplock baggies.

    Do I need to do anything to remove the lube before installation or is it okay "as-is"? Also, is that stuff going to fiddle with my pool chemistry once I start filling up the pool?

    Thanks for any thoughts or comments!
    16x48 Intex Ultraframe vinyl AGP, 2150 gph sand filter/pump (Intex SF70110), TF-100 test kit

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Tucson, AZ

    Re: remove lube or no?

    If it was appropriate lube, it should be fine to just reinstall and should have no effect on the chemistry.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts