Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 14 of 14

Thread: Aqua Rite SWG Low Salt and Check Cell Errors.

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    Newbury Park, California
    Posts
    7

    Aqua Rite SWG Low Salt and Check Cell Errors.

    I have an Aquarite SWG that has the Low Salt Error Light on and the Check Cell Error light on.

    I have replaced the cell and still have the same problem. It was 14 years old.

    I also replaced the Relays and the Current Limiter as described in other threads.

    The cell generates chlorine for about 45 seconds and then the error lights come on and it stops generating.

    Salt reading tested by salt strips is 2900.

    Display on chlorinator is 1900.

    Diag displays are
    temp 81
    volts 26
    amps 4.43
    Salt -1900
    Rev 1.09

    I believe that the amperage is supposed to be 6-8 amps.

    Any help would be appreciated.

    I do have reasonable electronic skills for diagnostic purposes.

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    Welcome to TFP!

    If you haven't already, take out the cell for a moment and visually examine the plates. If there is calcium scale (white chalky stuff) on the cell plates the cell needs to be cleaned.

    If the plates look clean, the odds heavily favor the test strips being wrong, and the salt level actually being low.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Jun 2014
    Location
    Newbury Park, California
    Posts
    7

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    I had the level tested at the good local pool store. Level was within 100ppm of my measurement.

    Cell is less than 2 days old.

    Any idea as to why the amperage is so far below the limits specified in the manual??

  4. Back To Top    #4

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    Which cell did you get?

  5. Back To Top    #5

    Join Date
    Jun 2014
    Location
    Newbury Park, California
    Posts
    7

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    A Ti Cell from Compupool

  6. Back To Top    #6

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    Which model?

  7. Back To Top    #7

    Join Date
    Jun 2014
    Location
    Newbury Park, California
    Posts
    7

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    GRC40GH is the model

  8. Back To Top    #8

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    That's the one that replaces the T-cell-15. The amps are a little low. I would suggest another test of the salt level just to be sure. If the salt level checks out, you might want to put in a warranty claim.

  9. Back To Top    #9

    Join Date
    Jun 2014
    Location
    Newbury Park, California
    Posts
    7

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    Yes that is correct. It does replace the T-cell-15.

    This is the second Ti cell I have had. This one is the warranty claim one. The previous Ti cell did exactly the same thing.

    The old T-cell-15 (15 years old) was showing the check cell lamp constantly and not making chlorine.

    I replaced it with the first Ti cell that was doing the same thing as the warranty replacement one that I installed a couple of days ago.
    I called Compupool and they said that the low amperage was out of spec so they sent me this new one.

    Is there something wrong with my control board??

  10. Back To Top    #10

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    It might be the lower quality cells. Based on the life of the original cell, it might be worthwhile to get an original cell. If you're going to do that, it might be worthwhile getting the power box as well.

  11. Back To Top    #11

    Join Date
    Jun 2014
    Location
    Newbury Park, California
    Posts
    7

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    I thought that might be possible.

    The Ti cell is about $250 cheaper than an original T-cell-15. $550 vs $300.
    Other people seem to have had good luck with the Ti cells.

    To get a complete new system is around $1700 plus install. Ouch.

  12. Back To Top    #12

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    The install is fairly straightforward since you already have the same system. You should be able to do it if you're reasonably handy.

    Maybe put in for another warranty claim?

  13. Back To Top    #13

    Join Date
    Jun 2014
    Location
    Newbury Park, California
    Posts
    7

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    Yes I am thinking of another warranty claim.

    You are right. I could do the install myself.

    Do you know of any electronic / electrical diagnostic info for the control board? ( voltages at test points or at various components)
    Could one of the bridge rectifiers be failing or the transformer? Or some 10 cent component?

  14. Back To Top    #14

    Join Date
    Jun 2014
    Location
    Roseville, CA
    Posts
    341

    Re: Aqua Rite SWG Low Salt and Check Cell Errors.

    I say do the warranty claim. If it is successful, you are golden. If not, you are where you are now.

    Probably the best time to buy a new unit is at the end of the season and the beginning of the season.
    SWG: CircuPool (May 2014) SI30+Plus; 3000ppm seems ideal;
    My Ideal Specs:
    FC 5; PH 7.4-7.6; TA 90; CH 350; CYA 75; = SI ~ 0.19
    14,000 gal, in ground, plaster, Cartridge filter, Borates
    TAYLOR K - 2006

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •