Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Aquarite control panel

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    Lake Havasu City, AZ
    Posts
    5

    Aquarite control panel

    Does anyone know what all the screen sequence numbers are? I just installed the AquaRite electronic chlorine generator on my existing fiberglass pool. The pool is 32x13x4 ft deep, actually 3 to 6ft deep so I figured 4 ft average. The pool was Crystal clean with proper balance prior to adding salt. I used the T Cell9 for pool size. I put in 400lbs of salt so far and its only reading 200ppm on salt screen. Also the cell says it needs inspecting already so I pulled it off and it is Crystal clean in there. Any words of wisdom? Like I said the manual doesn't show the screen meaning when you scroll through unless I am missing something???

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Aquarite control panel

    Welcome to TFP!

    The info when you cycle through the diagnostic sequence is:
    Temperature
    Volts
    Current
    Percentage setting
    Instant salt level
    Product name
    Software revision
    Cell type

    You need to program the cell type based on the cell you have installed or it will not work correctly.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Jun 2014
    Location
    Lake Havasu City, AZ
    Posts
    5

    Re: Aquarite control panel

    Hey thanks for the response... I've got the correct cell number entered and its been circulating now for 30+ hours. The salt level is now 100ppm after 480lbs of salt and the tcell light is still solid after cleaning, is this because the salinity is still to low or am I fighting a ghost??

  4. Back To Top    #4

    Join Date
    Jun 2014
    Location
    Lake Havasu City, AZ
    Posts
    5

    Re: Aquarite control panel

    Thank you for the welcome, I've heard nothing but good for this site from many people. Maybe if I give some more info it will be helpful. The pump I'm using is a brand new Hayward Eco Star SP3400VSP, Aqua Rite Chlorine Electronic Generator, and Hayward T Cell 9. My salinity is now zero today after 48 hrs circulation time and the impact cell light is illuminated, even though it is clean as a whistle after examination. I also cleaned the filter of which was not sorry at all. Am I still missing something? It has been about 108 here in Havasu and will get nothing but warmer throughout the summer.

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Aquarite control panel

    Salt reading zero, when the salt level is clearly much higher than that, suggests either that the cell cable is not properly connected, or that the current limiter has burned out. If you are handy with a soldering iron the current limited can be replaced fairly easily.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  6. Back To Top    #6

    Join Date
    Jun 2014
    Location
    Lake Havasu City, AZ
    Posts
    5

    Re: Aquarite control panel

    Also this is what my Aqua Rite control mod is saying when I scroll through it
    0
    80
    32.2
    0.00
    50P
    - 0
    AL-0
    R 1.59
    T-9

  7. Back To Top    #7

    Join Date
    Jun 2014
    Location
    Lake Havasu City, AZ
    Posts
    5

    Re: Aquarite control panel

    Where is the current cell located? Is that the flow indicator? The one downstream of the cell? I may have turned it on prior to water flowing, could this cause the meltdown????

  8. Back To Top    #8
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Aquarite control panel

    Cell current is zero, and instant salinity is zero, which strongly suggests the current limiter problem (assuming you have checked the connection where the cell cord plugs into the control box). This topic discusses this issue at length, though there is a fair bit of confusing information mixed in.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •