Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pulled out leaking raised spillover spa

  1. Back To Top    #1

    Join Date
    Jun 2014
    Riverton, Utah USA

    Question Pulled out leaking raised spillover spa

    Hi. We had an inground fiberglass pool with a raised spill over spa. It worked great for a few years but then it just kept failing and the pool was always getting filled with rocks and dirt. Last week we finally pulled the spa out because it appeared that all the leaking was coming from that area. Now we have an empty hole around the pool deck where the spa was and several pipes. We connected the 2 1/2" PVC pipe together and capped off the flexible pipe because we didn't think we would need the flexible pipe if we are going to just cut it from the source however, we are now in a mess because we don't know if the flexible pipe should be connected with the other flexible pipe. There is a return inlet right below where the spillover spa was that was originally supposed to be used as a vacuum port but we can't get the system to function properly if we turn the valves the other direction. Right now we have the water circulating through the skimmer and main drains back into the returns (both the valves at the equipment have the spa turned off) but when we vacuum through the skimmer there seems to be water leaking over by the vacuum port (which is no longer a vacuum port as it only shoots water into the pool at this point) Also, it seemed as if the light was leaking so we have tightened it up and put new silicone around the fitting but really have no clue what plumbing is necessary and which lines can be cut all together. We capped off any that had water going through them after we pulled out the spa except the obvious one needed to keep the water flowing throughout the pool. I will attach a picture so maybe someone can help… Please…. Plus with the plumbing back at the equipment I am not sure of any of the schematics and whether or not we need to get new valves.
    Thanks in advance and I hope you don't think I am an idiot..
    ps. We originally started out with two pumps and an air blower that went directly to the spa until someone jumped the fence and cut the pump off. So then we plumbed both to use the same pump.
    We would like to simplify as much as possible and just have the unground pool without any other fancy stuff.

    also… how do I connect the pics?

  2. Back To Top    #2

    Join Date
    Aug 2013
    Oklahoma City, OK

    Re: Pulled out leaking raised spillover spa

    Pictures would help us figure out how to fix your isssue.
    20000 Gallon, Sand Filter, IG Plaster, Hayward Aqua Rite 40k SWG, TF-100 Test Kit, Taylor SpeedStir

  3. Back To Top    #3

    Join Date
    Jan 2013
    Houston, TX

    Re: Pulled out leaking raised spillover spa

    Welcome to TFP!

    There are 2 ways to get pics up - use a hosting site like photobucket and linking or post to the forum using tapatalk from your mobile device, it has a feature that handles all of the image hosting.

    Full Guide Here: How to Add Pictures
    TFP Moderator Chris V. ~16K Pool & Spa, 48NSF DE, IG Plaster Circa 2000, Intermatic PE653, Challenger pump with a 2 speed B2984, 20gal stenner chlorine injection, Houston, TX
    One cannot follow Islam and Christianity at the same time, nor can one follow pool store methods and TFP at the same time.
    Pool School -- Pool Math -- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts