Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Timer Problems, Spa Problem (Air System), and Light Problem.

  1. Back To Top    #1

    Join Date
    Oct 2012
    Location
    Houston, TX
    Posts
    29

    Timer Problems, Spa Problem (Air System), and Light Problem.

    We just moved in here 2 weeks ago, and i'm slowly getting to each issue around the house. I just finished the slam and all is well chemistry wise. Yes i know i need to fix/ replace the conduit)

    Here is my timer. Its a two unit timer, the left one running the main pump 2.2HP Centurion, and the right side running my booster pump for my pool cleaner. The time on the booster pump doesnt keep time? Ideas on troubnleshooting this?


    Here are the air controls. I Have pulled out the air switches, and gotten a small piece of tubing. One switch functions properly and the other is trash. The box on the Left Clicks as if it is getting the air pressure signal whenn i hook up the switch and short tube, but nothing turns on. (the box has power). The box on the right on the other hand, does nothing when hooked up to the working air switch.... Any ideas on trouble shooting this?


    Now the real irritating one... I pulled the light last week, and took it apart, the bulb was broken in half, and i had to remove the base with the old pototato trick. Here is where it gets strange (no water in unit). There is power to the unit at the cylindrical thing on the left of the bulb socket thats covered in paper(capicitor? resistor?), but no power to the base of the bulb socket. Theres power at the light switch and the gfci, so i assume i just need to replace the whole thing???
    40,000 gallon ig gunite, Pentair Challanger Century Centurion 2.2 HP Pump, FNS 60 DE filter, Polaris 280, Century Centurion 3/4 HP Booster Pump, Attached ig spa - 1HP Centurion pump - Dual non functioning blowers

  2. Back To Top    #2
    gtemkin's Avatar
    Join Date
    Jun 2008
    Location
    Seattle, WA
    Posts
    738

    Re: Timer Problems, Spa Problem (Air System), and Light Problem.

    Looks like the timer motors for both of the timers are drawing power from the exact same terminals - the ones the white wires are connected to. So since one is working and one is not, I'd say the one that's not has a bad timer motor. I believe those are available as a replacement part. Don't know about you're other problems.
    21K gal 16' x 40' in-ground pool built 1959, old school with Jacuzzi bronze pump, American Products 24" Sand Filter & Americana Multiport valve, Jandy Lite2 millivolt heater, Coverstar cover, and classic Kreepy Krauly.

  3. Back To Top    #3

    Join Date
    Oct 2012
    Location
    Houston, TX
    Posts
    29

    Re: Timer Problems, Spa Problem (Air System), and Light Problem.

    yes, that myst be it when i look in the "visual motor check, i can see the one on the leftw orking, but the right one is stalled. Ill try and find a model number and order a new one. Any one have ideas on the air system or light fixture?
    40,000 gallon ig gunite, Pentair Challanger Century Centurion 2.2 HP Pump, FNS 60 DE filter, Polaris 280, Century Centurion 3/4 HP Booster Pump, Attached ig spa - 1HP Centurion pump - Dual non functioning blowers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •