Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: I need help with StaRite MaxETherm heater.

  1. Back To Top    #1

    I need help with StaRite MaxETherm heater.


    I have a 400k btu NG unit and the heater itself works fine. Trouble is the buttons to adjust the temperature are not responding. It won't allow me to change the final temperature. It doesn't matter if it's on "pool" or "spa". This has been going on for years but before I would be able to get it to change temps after fiddling with the buttons a bit but now it's finally stopped working.

    Does anyone know how to test if it's the actual buttons that are faulty or if it's a control board issue? I don't want to buy incorrect parts since they're astoundingly expensive and can't be returned. I'm hoping it's just the buttons since that part is half price of the control board.

    Thanks a ton for the help!
    15,500 gal, inground gunite pool with 7 ft spa, 2 speed pump 2hp/.33hp, 3/4 hp booster pump, Intermatic P1353 timer, AutoPilot SC-48, Sand filter with ZeoBest, Heater, that I never use . . .

  2. Back To Top    #2

    Join Date
    Sep 2007
    Rochester, NY

    Re: I need help with StaRite MaxETherm heater.

    From your description it's time to replace keypad. I had the same problem.

    I just bought one through for $58. Pentair 42002-0029Z Switch Membrane. I'm going to install it today.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts