Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Going Crazy Sta-Rite PD-50

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    Londonderry, NH
    Posts
    4

    Going Crazy Sta-Rite PD-50

    Hello, this is my first post here and I appreciate any help in advance.

    We have owed our pool - an 18' x 33' x 52" - for over 15 years and I have never had an issue with keeping a sparkling clean pool. Chemistry is always in range and the pool has been headache-free until this year.

    As stated, we have a Sta-Rite PD-50 pool filter that takes 6 pounds of DE. Typically, I add the DE by diluting each scoop in a few gallons of water and slowly pouring into the skimmer basket. At that point, my pressure has been about 10 pounds to start.

    This year, I cannot get the pressure to reach 10 pounds or move at all. The gauge is working as putting my hand over the return line will cause it to rise. When I open the filter the DE is not evenly dispersed on the element. I have tried several times - all with the same results. The top of the filter (horizontal part) is covered with a pile of DE, the upper vertical mesh is not covered until about 1/2 way down, and even that is somewhat sporadic.

    I believe that it may be air in the system but the pre-filter gasket seal is fine as is the main O-ring for the cover. The drain on the pump and strainer are also not leaking, nor are any of the hoses or fittings.

    The real kicker is that the first time I charged it a week ago, it was fine. I was vacuuming the pool and all was working as it normally is. Once the suction decreased, and I cleaned the filter, I have not been able to get it working again. Something changed very quickly and I cannot troubleshoot it.

    Any guidance is appreciated...

  2. Back To Top    #2

    Join Date
    Jun 2014
    Location
    Londonderry, NH
    Posts
    4

    Re: Going Crazy Sta-Rite PD-50

    Figured it out. Even though there was not a 'leak' per se, I found that there was air in the filter. Moving backward, there was air in the pre-filter strainer. The level to the skimmer was fine, so no air getting in at the beginning. The hoses were tight. The fitting right after the hose but before the pre-filter strainer leads into a shut-off valve. If the fitting it tightened too much, the valve will not turn, so it typically is not tightened too much. I shut the filter down and tightened this fitting a little more. It was actually a little loose, but not leaking. Once I tightened it and re-started the filter the pressure came up to 10 psi. I drained the filter, re-coated the mesh with DE and within 24 hours the water is crystal clear.

  3. Back To Top    #3

    TFP Guide

    laceygirl's Avatar
    Join Date
    Dec 2013
    Location
    Canberra Australia
    Posts
    1,240

    Re: Going Crazy Sta-Rite PD-50

    Well done on troubleshooting it yourself... Welcome to TFP, sorry none of us were much help to you.... Glad your pool is crystal clear...
    Intex Rectangle 18 x 9 x 52', 4544 gallon (18000 litres), 0.75 hp pool pump, 100 sqft Zodiac Titan Cartridge Filter - 40mm, Stenner Peristaltic Pump chlorine injection system, Intex Over The Wall Skimmer, Intex Fittings with 40mm plumbing Lil Patch Of Heaven. Build/Construction http://www.troublefreepool.com/threa...lice-of-heaven

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •