Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Venturi air not working on pool sit-n-spa step

  1. Back To Top    #1

    Join Date
    Jul 2007
    Location
    Ohio
    Posts
    47

    Venturi air not working on pool sit-n-spa step

    OK, I am one of the lucky people that chose a builder that goes under within 7 months of your pool being built, so TFP is now my ONLY source of information... Albeit, it has alway been much better information!

    So, My builder installed my sit-n-spa step, with 3 jets last fall. All was well. They helped me close the pool this winter. We didn't do anything special with the actual venturi system, just blew out the spa step lines and sealed for the winter.

    So, since I opened the pool this spring, I can pump water to my seat, but when I open the twist valve that "activates" the Venturi system, I get no air. Actually, when I turn it on it has water flowing out of the venturi spin cap.

    Any suggestions?

    Thanks ahead of time, Chuck
    16X24X40 Grecian L Vinyl Pool - Dig 9/4/2007 and first swim 9/21/2007
    Located in Ohio Approx 27K gallons
    Pentair Whisperflow 1 HP 2-speed Pump
    Hayward Sand Filter Jandy AE2500 Heat Pump
    Autopilot Dig-220 w/sc-60 cell

  2. Back To Top    #2

    Join Date
    Mar 2007
    Location
    Coastalish 'down easter'
    Posts
    4,160

    Re: Venturi air not working on pool sit-n-spa step

    Chuck, my first thought is an obstruction in one or more of the returns the venturi feeds. I know you said water is flowing into the swim-out, but I've seen it on spillover spas when some of the returns are closed, or a rock was in the line and is blocking the return (the ones we use have the water feed tube that can be removed (from the pool side) with a 9/16" socket) If you didn't seal the return port after winterizing, some rodent may have made it home for the winter and brought a supply of acorns . what I'd do first is to poke a screwdriver into the returns and se if you feel an obstruction (with the filter on and the returns on).

    Please try this and get back
    Luv& Luk
    -Ted

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

  3. Back To Top    #3

    Join Date
    Jul 2007
    Location
    Ohio
    Posts
    47

    Re: Venturi air not working on pool sit-n-spa step

    I have attached two photos of the twist valve to allow air in. I sealed the return line in the winter, and I am getting good water flow from the pump, so there is no obstruction.

    What i did do over the weekend was to take my air compressor and blow air down into this opening. I had someone help, and we could put our hands over the 3 jets in the steps one at a time and force the air from the compressor to each one. Of course, the air "action" was great at that point! After I stopped, it would continue to "add air" for 3-5 seconds. then I would hear a gurgling as it sounds like the Venturi valve thing was fillling up with water, and the bubble/air action would stop.

    --Chuck
    Attached Images Attached Images
    16X24X40 Grecian L Vinyl Pool - Dig 9/4/2007 and first swim 9/21/2007
    Located in Ohio Approx 27K gallons
    Pentair Whisperflow 1 HP 2-speed Pump
    Hayward Sand Filter Jandy AE2500 Heat Pump
    Autopilot Dig-220 w/sc-60 cell

  4. Back To Top    #4

    Join Date
    Mar 2007
    Location
    Coastalish 'down easter'
    Posts
    4,160

    Re: Venturi air not working on pool sit-n-spa step

    If it's not an obstruction at the jets, I'll have to say you aren't generating enough flow through those returns to entrain the air. Try running the pump on high speed and closing off the other returns in the pool.
    Luv& Luk
    -Ted

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

  5. Back To Top    #5

    Join Date
    Jul 2007
    Location
    Ohio
    Posts
    47

    Re: Venturi air not working on pool sit-n-spa step

    Waste,

    I'm sorry, I should have stated that. When attempting to get this going, I do shut of the main return lines so ALL flow is going to the step, and the pump is on high. It puts through a ton of pressure. I have deck jets also and when I have them open, I can shoot water 20 feet in the air from both of them!
    16X24X40 Grecian L Vinyl Pool - Dig 9/4/2007 and first swim 9/21/2007
    Located in Ohio Approx 27K gallons
    Pentair Whisperflow 1 HP 2-speed Pump
    Hayward Sand Filter Jandy AE2500 Heat Pump
    Autopilot Dig-220 w/sc-60 cell

  6. Back To Top    #6
    DaveNJ's Avatar
    Join Date
    May 2007
    Location
    Toms River, NJ
    Posts
    520

    Re: Venturi air not working on pool sit-n-spa step

    When my pool was installed one step jet didn't work. An o-ring was missing on the jet assembly. Water would flow fine but no air. I have a much different setup both worth checking the jets out.
    IG 18x36 oval vinyl, Spill over spa, Northstar 2hp-2spd, 2.5" piping, S310T 500lb Sand filter, 400k gas heater, AutoPilot SWCG
    http://www.tftestkits.net/

  7. Back To Top    #7

    Join Date
    Jul 2007
    Location
    Ohio
    Posts
    47

    Re: Venturi air not working on pool sit-n-spa step

    So, in going with the o-ring theory. I took out all 3 jets, and took a picture for reference. I used the winterizing winter caps and sealed 2 of the 3 openings off. Then I tried each jet in the fitting left open. None of the jets worked. Did this with the pump on high and low, and with my other return lines open and closed (attempting to see if various pressures would cause it to work). No luck with anything. Actually, water would most often come up out of the Venturi air cap when I opened it. Do notice in the jet on the left in the picture, there is NOT an o-ring, but it has a different type of locking ring. The inside end of that jet appears different to me, and it looks to make sense that it does not have an o-ring????

    I can reach my fingers back in the step jet fitting, and feel the dime-nickel sized how at the top of the fitting where the AIR is supposed to enter. I know that is the air fitting, as I can Blow into the Venturi opening on the deck and feel the air coming out of that hole.

    So, still I have NOTHING and kinda clueless on what else to try.

    --Chuck
    Attached Images Attached Images
    16X24X40 Grecian L Vinyl Pool - Dig 9/4/2007 and first swim 9/21/2007
    Located in Ohio Approx 27K gallons
    Pentair Whisperflow 1 HP 2-speed Pump
    Hayward Sand Filter Jandy AE2500 Heat Pump
    Autopilot Dig-220 w/sc-60 cell

  8. Back To Top    #8
    DaveNJ's Avatar
    Join Date
    May 2007
    Location
    Toms River, NJ
    Posts
    520

    Re: Venturi air not working on pool sit-n-spa step

    Check out the link below. Match up your jets and see if everything is there.

    http://www.spadepot.com/shop/pcategory. ... 208&Page=3
    IG 18x36 oval vinyl, Spill over spa, Northstar 2hp-2spd, 2.5" piping, S310T 500lb Sand filter, 400k gas heater, AutoPilot SWCG
    http://www.tftestkits.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •