Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: pump will not prime

  1. Back To Top    #1

    pump will not prime

    Hi Guys, I have a friend with a Sta-Bilt 3/4 horse and it will not prime. The pool is full to the overflow, I have check all fittings nothing loose or cracked. Line from skimmer not stopped up. I removed the cover and the discharge line. Filled the pump and turn it on. It pumps very little but the garden hose supplies more water than it will pump. I have the pump housing separated and nothing is broken or clogged. There is no water leaking. I am at a loss. Please help. Thank You
    Playas Del Coco, Costa Rica
    36'X16' in-ground. 25000 gallon
    3/4/HP Hayward with 280 pound sand filter
    AquaRite SWG

  2. Back To Top    #2
    Mod Squad woodyp's Avatar
    Join Date
    Apr 2010
    Location
    East Texas
    Posts
    9,004

    Re: pump will not prime

    Is the impeller broken or clogged?
    16x32x52" Steel Cornelius Miramar AGP Vinyl liner 13,100 gal. Buried 2 ft.
    2 Speed Hayward Power-Flo Matrix 85 g.p.m. 22" 250lb. sand filter hard plumbed
    Pool Rover Jr., Pool Blaster Max, Diver Dave TF100 Test Kit/Speed Stir
    Margaritaville Frozen Concoction Maker, Liqour Chiller, & Drink Mixer & Party Tub----Collect 'um all!

  3. Back To Top    #3

    Re: pump will not prime

    If it's old, it could be the motor. How hot does the housing get? I had to replace mine because the pump would overheat and shut off quite frequently.

    That impeller needs to be able to easily spin. Check inside the translucent impeller cover to see if any of the fins are damaged.

  4. Back To Top    #4

    Re: pump will not prime

    Nothing broken or clogged and motor runs fine
    Playas Del Coco, Costa Rica
    36'X16' in-ground. 25000 gallon
    3/4/HP Hayward with 280 pound sand filter
    AquaRite SWG

  5. Back To Top    #5

    Re: pump will not prime

    Is the return line clogged?

  6. Back To Top    #6

    Re: pump will not prime

    Quote Originally Posted by Tyrone Shuz View Post
    Is the return line clogged?
    No disconnected
    Playas Del Coco, Costa Rica
    36'X16' in-ground. 25000 gallon
    3/4/HP Hayward with 280 pound sand filter
    AquaRite SWG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •