Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Jandy EI Aquapure 35 - blinking red flow light.

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    New York, NY
    Posts
    13

    Jandy EI Aquapure 35 - blinking red flow light.

    All,

    I have a 2 year old Jandy chlorinator that worked fine at the end of season last year. But now when I turn it on I just get a blinking red flow light (every few seconds).

    The pool jet flow is actually super great and the cell is squeaky clean.

    What's odd is that the unit doesn't actually appear to power on correctly. In the past, the fan would whir and I would get LCD messages.

    Now when I plug it in, it just does this blinking light thing. The normal "boot up" process seems to not happen at all now. No LCD messages whatsoever - not even the old "NO FLOW!" message you normally get when you turn the pump off.

    Not sure what else to do but advice is appreciated.

    Thanks,

    -G

  2. Back To Top    #2

    Join Date
    Jun 2014
    Location
    New York, NY
    Posts
    13

    Re: Jandy EI Aquapure 35 - blinking red flow light.

    Solved my problem. I took the unit apart and discovered that the ribbon cable that connects the LCD was off on one side. I pressed it back in and it powered up no problem. The flow light condition immediately cleared. Now it's just saying I need more salt - which is great to learn since that's a problem I totally know how to fix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •