Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Aquarite no led's lit, but diagnostic display works.

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    Atlanta Ga.
    Posts
    4

    Post Aquarite no led's lit, but diagnostic display works.

    I am new to this forum, and need help. I have an Aqua Rite salt generator 5 years old. 18 x 36 inground pool. the t cell went out last week, I ordered a new one exact same cell that it came with it. T-cell 15, received it installed it yesterday, and it worked perfectly all day. Today I went out to check the salt reading and all of the led's are out. The display still works and the readings are :
    salt 3500
    temp 84
    volts 0.1
    currant 0.00
    output 84p
    salt -0
    al 2
    rl 1.40
    Checked the fuse, it's good. unplugged cell, plugged it back in, turned on and off several times. No flow light blinks for about 30 seconds, goes off, generating light comes on for a couple of seconds and goes off. Help please 90 degrees in Ga. will be green soon.

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Aquarite no led's lit, but diagnostic display works.

    Welcome to TFP!

    This could just be a loose connection where the cell cable plugs into the control box, but it might also be the current limiter being burned out. If you are handy with soldering, it is possible to replace the current limiter yourself quite inexpensively.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Jun 2014
    Location
    Atlanta Ga.
    Posts
    4

    Re: Aquarite no led's lit, but diagnostic display works.

    Is it normal for it to burn out at the same time the cell goes out? Is this the currant limiter, and is there a way to check it? Thanks Joe Digi-Key Part Number 570-1062-ND

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •