Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Waste Valve Leaking Water

  1. Back To Top    #1

    Waste Valve Leaking Water

    First time opening a pool. Water is trickling out of my filter's waste port. Multi-port valve (MPV) is aligned correctly. Pump always turned off before changing settings. When analyzing the spider gasket, I noticed one small section (.25") kept popping out of place and would allow grass / debris to get stuck between the gasket and the plastic. Drying the MPV head and spider gasket and replacing didn't work. I then used RTV silicone to apply the gasket and waited 24 hours to replace but the trickling remained. Gasket integrity seems fine and even before applying the silicone, it had a snug fit.

    After thinking about it as I'm writing this, a concurrent observation along with this issue is that I do see a small pinch of sand in one of the MPV compartments and there is maybe half a cup of sand at the bottom of the pool near the return. This is starting to sound worse than I thought! Any ideas?

  2. Back To Top    #2

    In the Industry
    duraleigh's Avatar
    Join Date
    Apr 2007
    Sebring, Florida

    Re: Waste Valve Leaking Water

    Have you tried a new gasket yet or just refitting the old one?
    Dave S. - Forum owner
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3

    Re: Waste Valve Leaking Water

    I'm assuming it's an older one but I'm not sure (yellow gasket). It doesn't feel brittle and it fits snuggly. A guy at the pool store says that if it's not the gasket (old one glued on), it's the MPV and it needs to be replaced - $79 Pentair after-market. I wanted another opinion before making the purchase.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts