Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Spa Air Blower does not work

  1. Back To Top    #1
    Fleur's Avatar
    Join Date
    Jul 2011
    Phoenix, AZ

    Unhappy Spa Air Blower does not work

    Hello everyone,

    We had our chlorine generator & one of the pool pumps replumped ~ a year ago (there was a leak at the connection and pipes deformed under our AZ sun). A couple of months after that I turned on our air blower for the first time and saw that it did not create any bubbles. It would start, I could hear noise, but no bubbles. Every time I turned it off, it made a popping sound. I tried several times with the same result. Since we did not use our spa in winter, I forgot about it. I had the same experience yesterday when I turned on our air blower, but the second time around it would not even start anymore (at least I do not hear any noise coming from it). I do not think replumbing had anything to do with it -- probably it is just a coincidence, but I wanted to mention it in case they could have switched some valve. I have no idea how our spa air blower works.
    Is there anything I could try to make it work or I have to leave it to professionals?

    Thank you!
    AG SWG ~15,000 Pebble Tec + Spa :: Intellichem, SWG IntelliChlor IC40, Pentair Intelli pH, Clean & Clear Plus filter (spa), Triton II Sand Pool Filter, MiniMax NT heater, Jandy NeverLube valves X8
    Pentair IntelliFlo 3HP VS (pool filter), WhisperFlo 3 HP 1.15 SF (hot tub jets), SuperFlo VS (spa filter), Challenger 1 1/2 HP 1.47 SF (water features: spillway, fountains)

  2. Back To Top    #2

    Re: Spa Air Blower does not work

    Last year after opening our blower would sound as if it were running but not make bubbles. I could get the bubbles going by priming the spa pipe with our leaf blower and then hurry up and put the running blower back on the spa pipe. This just proved there was no leak. Ultimately, I just replaced the blower and everything works perfectly.
    21K gal SWG gunite pool/spa/waterfall, Goldline ProLogic controls, 2 2.0 HP Hayward Northstar pumps, hayward heater, 4 cartridge, Polaris 9300 sport robot, TFP-100 test kit owner

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts