Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pentair Minimax Plus 400 Problem

  1. Back To Top    #1

    Join Date
    May 2013
    Falls Church, VA

    Pentair Minimax Plus 400 Problem

    After my usual getting rid of cob webs, leaves etc. my 13 year old heater fire right up again this season. It easily ran for 12 hours and the water was warm. But it stopped with the Heat indicator light out and the service light on with the associated clicking noise. I did more cleaning the next day and it worked for a couple of hours and then stopped. A tech at Pentair deduced it was a water flow problem since it works but shuts off after a while (thus not voltage/gas) and suggested I replace the flow valve assembly. I did that and it ran for six hours before stopping again with the same indicator lights. I think it ran longer than the previous try because the water had cooled down over several days. Anyone have anything like this or ideas whatís happening? It seems more heat oriented than flow oriented to me. Although the unit is old, itís still clean and heats well.
    11.5k gal, IG Plaster (2001), 1.5 HP Pentair Ultra-Flow Pump, Purex Triton FNS Plus 60 sqft DE filter

  2. Back To Top    #2

    In the Industry
    ps0303's Avatar
    Join Date
    Jul 2011

    Re: Pentair Minimax Plus 400 Problem

    Did you possible disturb some wires inside when cleaning? With the power of to the unit, check the wires and connectors and make sure they are securely fastened.

    A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts