Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pentair Mastertemp 400 - Can't change temperature

  1. Back To Top    #1

    Join Date
    May 2014
    Dallas, TX

    Pentair Mastertemp 400 - Can't change temperature

    First, I just wanted to say thanks to this site for all of the helpful info and great people. My girlfriend and I recently purchased a house with a pool and spa, and knew little to nothing about maintaining and operating either one of them. This site and the information on it has been a huge resource for us to get started, thanks to everyone who contributes!

    On to the issue. We have a Mastertemp 400, and when we first looked at the house, it was not working (e05 code I believe). One of the conditions of us buying the house was for the previous owner to get that fixed, and they did. The membrane and control board were replaced 4-5 weeks ago. Our first week or so in the house we used the spa, and it seemed to work just fine. This weekend however, I realized the temperature wasn't going up as high as I wanted, so I went to the heater and tried to turn the temperature up. The button to raise the temperature however would not do anything. I tried the down button, it DID work. I thought maybe there was just a lose connection or something so I turned it off and unplugged/re-plugged the cord running to the membrane and a few other. Still, same problem, and at this point I have turned the temperature down too far to be useful (70s). I then went to our main control board for the pool and spa and pressed the reset button.

    After resetting everything, neither the up or down temperature buttons, nor any of the other buttons seem to work. I believe that if the temperature could be raised, the heater and everything would still fire. The membrane was just replaced a month ago, could it possibly have already gone bad again, or does this sound like something else?

    Any help is much appreciated!

  2. Back To Top    #2

    Join Date
    Apr 2017

    Re: Pentair Mastertemp 400 - Can't change temperature

    Looking for an answer to this myself

    - - - Updated - - -

    I am also unable to raise the temp on my heater. Same one. I hit the yellow reset button No change. Any answers out there

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts