Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Trouble with Solar Install - Need Advice

  1. Back To Top    #1

    Join Date
    May 2014
    Location
    United States
    Posts
    2

    Trouble with Solar Install - Need Advice

    The problem is with my Pentair control panel - at least that what what my Solar Installer says.

    I haven't contacted Pentair yet, but thought someone on this forum might be able to shed some light on what the real issue might be.

    The Solar system was installed about a week ago. Part of the installation was hooking up the Solar switch to the Pentair control panel. The tech "enabled" the Solar feature on the panel, but didn't actually check to make sure it worked. It didn't. I figured out after a couple of days that the Solar switch was actually in the "off" position (the pool didn't heat up but a couple of degrees over two hot days).

    To make a long story a bit shorter, it turns out that the Enable/Disable function on the Pentair is reversed. When "Disabled", the Solar switch can be turned on manually via the solar button. When "Enabled" there is no way to turn on the solar unit at all. Even the manual button won't work.

    The Installer sent out a tech who was not very helpful. First, he thought I was wrong and that the unit was functioning correctly. I had to take him through the sequence to convince him there was actually a problem. Once he realized the problem is real, he said the problem is in my Pentair control unit, and that everything was wired up ok on their end. He suggested I contact Pentair, and just operate the system manually until it gets fixed. I actually wouldn't mind this, except it is my understanding that if the pool should overheat that the unit won't automatically shut off unless Solar is enabled.

    Has anyone ever run into this problem? Is it possible the install was wired up backwards, and I'll just get into a "he said - she said" situation?

    Any and all advice appreciated.

  2. Back To Top    #2
    Casey's Avatar
    Join Date
    Apr 2007
    Location
    SW PA
    Posts
    10,157

    Re: Trouble with Solar Install - Need Advice

    It certainly sounds like it's backwards! Hopefully someone with more experience will be along shortly!
    I'd bet you my bikini you'll never get TFP water from a pool store!

    24' Sharkline Venture De Filter

  3. Back To Top    #3
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Trouble with Solar Install - Need Advice

    Welcome to TFP!

    Your description of the controller settings does not correspond with the way it is supposed to work.

    When solar is globally disabled the front panel solar button still manually controls the solar valve. When solar is globally enabled the solar button switches between a locked off state and automatic thermostatically controlled solar heating.

    From your description, it sounds like something is setup incorrectly causing the automatic thermostatic control to never turn on. There are a number of things that all need to work together for solar heat to turn on in automatic mode. The solar and water temperature sensors must be installed and working. Solar needs to be enabled in the settings menu. The solar sensor temperature reading must be at least N degrees warmer than the water temperature (where N is set in the solar settings menu). The water needs to be colder than the configured water temperature (heat menu). Heat must be setup for solar only or solar pref (heat menu). And the pump needs to be on.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  4. Back To Top    #4

    Join Date
    May 2014
    Location
    United States
    Posts
    2

    Re: Trouble with Solar Install - Need Advice

    Quote Originally Posted by JasonLion View Post
    Welcome to TFP!

    Your description of the controller settings does not correspond with the way it is supposed to work.

    When solar is globally disabled the front panel solar button still manually controls the solar valve. When solar is globally enabled the solar button switches between a locked off state and automatic thermostatically controlled solar heating.

    From your description, it sounds like something is setup incorrectly causing the automatic thermostatic control to never turn on. There are a number of things that all need to work together for solar heat to turn on in automatic mode. The solar and water temperature sensors must be installed and working. Solar needs to be enabled in the settings menu. The solar sensor temperature reading must be at least N degrees warmer than the water temperature (where N is set in the solar settings menu). The water needs to be colder than the configured water temperature (heat menu). Heat must be setup for solar only or solar pref (heat menu). And the pump needs to be on.
    Thank you, Jason. Sure enough, when I enabled the Solar, the "Heat" menu displayed the heater options. I set the Heat option to "Solar" and the unit turned on.

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Trouble with Solar Install - Need Advice

    Which specific model of Pentair automation do you have?
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •