Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Hayward Aqua Plus PCB Connector @ J8

  1. Back To Top    #1
    mpride's Avatar
    Join Date
    May 2008
    Sugar Land Texas

    Hayward Aqua Plus PCB Connector @ J8

    I have a wire that came loose from the connector on the plug that plugs into my main circuit board at position J8. I cleared the remnants of the insulation etc but I can't get the wire to stay in the connector and make a good connection. Does anyone know what type of plug this is? I'd like to replace it.
    IG Gunite * White Plaster * 26'9" x 14' * 310sqft * 70' Perimeter * 9300 Gallons * 2 Main Drains
    2 Skimmers * 4 Jets * Aqua Plus Control System * Aqua Rite Salt System * C3025 Cartridge Filter
    Tristar 2HP 2 Speed Pump * H400K Heater * Phantom w/Booster Pump * ColorLogic

  2. Back To Top    #2

    steveg_nh's Avatar
    Join Date
    Oct 2013
    Southern NH

    Re: Hayward Aqua Plus PCB Connector @ J8

    How old is the AP system? You either have a 1 or 3 year warranty, depending on your other equipment I believe. I would imagine Hayward may be able to help you too. I've found their customer service to be pretty solid.
    24'x40' 25k gal Imperial Mountain Pond IGP, full 28 mil VynAll Ocean Breakers liner. All Hayward system: 140k BTU HeatPro heat pump, 3/4HP single speed TriStar 2" Pump, DE6020 filter, AquaPlus Automation/Salt Chlorination, remote controls, ColorLogic 4.0 lighting. Polaris 280 w/PB4-60 BP. TF100 & K1766 test kits. Rinox Palazzo pavers and Spherik coping. Pool installed 9/2013, project completed 6/16/14.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts