Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 10 of 10

Thread: No flow light stays on hayward aqua trol SWG

  1. Back To Top    #1

    Join Date
    Apr 2012
    Location
    South east VA
    Posts
    26

    No flow light stays on hayward aqua trol SWG

    I have a Hayward aqua troll SWG, I turned it on for the first time this spring and the no flow light stays on. I had to buy a new flow switch for it this year as the one last year the wire got cut. All I did was unscrew the other one and screw the new one on. It doesn't matter what kind of flow switch it is does it? I figure they all should be about the same. I also read that you should make sure the arrows on the flow switch is facing same direction as the flow of water, but I didn't see any arrows on the switch it self.

    Anything else I should look for? The wire looks good and no damage to it, everything else is connected properly. I hate to buy a new switch if it is something simple I'm missing.

  2. Back To Top    #2

    Join Date
    May 2014
    Location
    Georgia
    Posts
    2

    Re: No flow light stays on hayward aqua trol SWG

    Hold the diagnostic button down for 5 seconds for the system to reset

  3. Back To Top    #3
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: No flow light stays on hayward aqua trol SWG

    The flow switch must be installed in the correct orientation. Generally they have a paddle that must be pushed by the flowing water. If they are in the wrong orientation the paddle won't move and thus will indicate no-flow.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  4. Back To Top    #4

    Join Date
    Apr 2012
    Location
    South east VA
    Posts
    26

    Re: No flow light stays on hayward aqua trol SWG

    Quote Originally Posted by dcrnbrd View Post
    Hold the diagnostic button down for 5 seconds for the system to reset
    Thanks, just tried it...nothing seem to of happened when I did though. Also I now see the arrow on the switch and it is pointing in correct direction.

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: No flow light stays on hayward aqua trol SWG

    The next step requires a multi-meter. Get the leads of the flow switch disconnected from the SWG and measure the resistance. The resistance should be very low when water is flowing and very high when the pump is off. If that is not the case, there is something wrong with the flow switch.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  6. Back To Top    #6

    Join Date
    Apr 2012
    Location
    South east VA
    Posts
    26

    Re: No flow light stays on hayward aqua trol SWG

    Quote Originally Posted by JasonLion View Post
    The flow switch must be installed in the correct orientation. Generally they have a paddle that must be pushed by the flowing water. If they are in the wrong orientation the paddle won't move and thus will indicate no-flow.
    Thanks, I read someplace I can take the switch out and push the metal together and the flow light should go off which indicates it is working or not, does that really work? If so guess that is an easy test to test it out.

  7. Back To Top    #7
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: No flow light stays on hayward aqua trol SWG

    Yea, you can try that. That is simpler than the multi-meter test I was suggesting.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  8. Back To Top    #8

    Join Date
    Apr 2012
    Location
    South east VA
    Posts
    26

    Re: No flow light stays on hayward aqua trol SWG

    Quote Originally Posted by JasonLion View Post
    Yea, you can try that. That is simpler than the multi-meter test I was suggesting.
    Thanks, I tried that and the no flow stayed on when pressed together. So I guess it's a bad switch.

  9. Back To Top    #9

    Join Date
    Apr 2012
    Location
    South east VA
    Posts
    26

    Re: No flow light stays on hayward aqua trol SWG

    Didn't want to start a new thread for this, but have kind of a silly question. I'm about to send the switch back, is there anyway to stop the flow of water coming from the return jet without draining below it? Because when I unscrew the switch water keeps coming out from the hole that the switch was in. (At least I think its coming from the return jet)

  10. Back To Top    #10
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: No flow light stays on hayward aqua trol SWG

    You need to block the return and suction fittings with something. Depending on the shape/size of your fittings, a tennis ball or ping pong ball will usually block them fairly well.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •