Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Older Catalina Spa pumps

  1. Back To Top    #1

    Older Catalina Spa pumps

    I have a Catalina XL 13000 model spa and I don't think that all is well with my pumps. This tub has two pumps. One two speed that is through the heater and another that is single speed that is not connected to the heater. When the spa turns the single speed pump on I can see it has flow to some jets but it operates for a short time and turns off. This pump seems to run very hot as well. I did replace the bearings in both pumps as well as the seals and impellers over the winter. I do recall that one of the pumps had some corrosion on the winding. Both seemed to be turning freely after the rebuild. The pump is not kicking the breaker but rather seems to be throwing the thermal overload and shutting down that way. I don't know what the cause of the pump turning on is as it just seems to do that on its own. Any help would be greatly appreciated. Thanks Jim
    27 foot round above ground

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Tucson, AZ

    Re: Older Catalina Spa pumps

    Sorry I have no experience with this, but hopefully someone else will be able to help.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts