Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Hayward Xstream cover will not tighten

  1. Back To Top    #1

    Join Date
    May 2014
    Location
    United States
    Posts
    2

    Hayward Xstream cover will not tighten

    Hi all, I have had my hayward Xstream filter for four years. I am having an issue where the black locking ring binds before it is fully locked. If I force it it becomes welded on and is very difficult to remove.... Has anyone had this issue and is there a fix... I tried cleaning threads with toothbrush and soapy water...

  2. Back To Top    #2

    Re: Hayward Xstream cover will not tighten

    I have the exact same problem - used the toothbrush and detergent on the threads for the base and the locking ring, ordered a new O-ring, and made sure to apply Jack's lube. It still won't tighten down to where it 'clicks' - it binds up before the click. Very frustrating!
    WendyNat
    Va Beach
    18' round, 52" tall above ground pool
    2 speed cartridge filter

  3. Back To Top    #3

    Join Date
    May 2014
    Location
    United States
    Posts
    2

    Re: Hayward Xstream cover will not tighten

    So far the hayward response is replace o ring and install cover straight... Oring done no change and I am pretty sure it's going on straight given that it worked fine for four years... More to come

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •