Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Newbie -- Any advice most appreciated...

  1. Back To Top    #1
    Gen's Avatar
    Join Date
    May 2014
    Pikeville, Kentucky

    Newbie -- Any advice most appreciated...

    Hi. I'm Gen. Newbie here. Will post better introduction soon. I really could use some input from those of you who truly know your stuff. I'm a novice above-ground pool owner. We bought an Intex Ultra Frame 14 x 48" above ground pool last year. It came with the standard Krystal Clear Model 637R Filter Pump. It worked great for last season (approximately three months). This year, we got everything ready to go and .... pump doesn't work. Was working last year just fine last time we used pool...stored the pump...this year doesn't work. I realize these pumps are approximately $89.00 to replace, but if there is anything I can do until I can get a new one (can't until I get a couple more paychecks), then I would appreciate your advice. We tried the recommended troubleshooting listed in the manual, however, still not working. My husband then removed the back of the plug in (where the test and reset buttons are, and two of the screws that hold the wires are coated in rust. There was water in this plug in (I thought it was a closed casing -- designed for outdoor use??)... Why would they make a plug on the end of a pool that can take in water and/or moisture etc. from the elements? I suppose this is the reason our pump is not working. Is there anything we can do to fix this without getting a new pump or until we can get a new pump? Any other suggestions. Again, I realize that compared to the other members here, my question may sound ridiculous -- given the systems you all seem to have on your pools, but any suggestions would be appreciated. -Gen.

  2. Back To Top    #2

    Join Date
    Jun 2012
    western NY

    Re: Newbie -- Any advice most appreciated...

    so many possibilities here...Do you know if the circuit you are plugging it into has power? That would be the first place to start. I assume by "plug in" you mean the plug on the end of the cord. By your description, it sounds like it contains a GFCI device built into the cord end. You will need to clean up and dry out the connections in there if they are as you say they are. It may be that the GFCI device is not re-setting properly. If you verify that the power is indeed getting to the motor, it could be the motor/pump is frozen or jammed. You will need to access the impeller to see if it will turn freely. since you did not indicate any motor humming, I am going to suspect something wrong with the plug/recepticle

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts