Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Stenner pump stopped working!

  1. Back To Top    #1
    JimboAZ's Avatar
    Join Date
    Oct 2012
    Location
    Maricopa, AZ
    Posts
    103

    Unhappy Stenner pump stopped working!

    Hi All,

    Tonight I noticed that my stenner pump is no longer working. To be more specific, the pump motor turns on (makes noise), but the mechanism does not rotate. I've had the pump for less than a year. I was expecting some maintenance but this has me a bit worried.

    I'm using the 45MPHP10 on a timer. I'll contact US Water Systems (where I purchased it from), but if anyone has any pointers on what to look for, or replace, I'd all ears! Thanks!
    --22k gallon pool/spa, IG, pebble w/ glass beads/abalone, all tile spa w/ stacked stone and spillway, 30 sf waterfall, 3 telescopic fountains, EZ Touch 8
    --Pentair VS3050, Whisperflo waterfall pump, Clean & Clear 520 cartridge filter, Intellibrite 5G LED lights, Ozone, Q360 in-floor cleaning, 400k btu heater
    --100 perim ft pool, 25 perim ft spa, Depth 3.5' to 7', 405 sq ft travertine decking, TF100 test kit
    --Time Lapse Video of our Pool Build ---- Our Pool Build Thread

  2. Back To Top    #2

    TFP Guide

    laceygirl's Avatar
    Join Date
    Dec 2013
    Location
    Canberra Australia
    Posts
    1,240

    Re: Stenner pump stopped working!

    Have you pulled it apart yet?
    Intex Rectangle 18 x 9 x 52', 4544 gallon (18000 litres), 0.75 hp pool pump, 100 sqft Zodiac Titan Cartridge Filter - 40mm, Stenner Peristaltic Pump chlorine injection system, Intex Over The Wall Skimmer, Intex Fittings with 40mm plumbing Lil Patch Of Heaven. Build/Construction http://www.troublefreepool.com/threa...lice-of-heaven

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Stenner pump stopped working!

    Do you have one of the new designs that has the clips on the side of the pump tube housing? If so it's extremely easy to take apart.

    Since it's less than a year old it's probably best to wait to hear from them before taking it apart.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4
    JimboAZ's Avatar
    Join Date
    Oct 2012
    Location
    Maricopa, AZ
    Posts
    103

    Re: Stenner pump stopped working!

    Thanks for the feedback so far. I have the new style so it's easy to remove the cover using the clips. But once it's open I'm not really sure what to do/look at. I should hear back from US Water soon. I'll be sure to update this once I figure out what's going on.
    --22k gallon pool/spa, IG, pebble w/ glass beads/abalone, all tile spa w/ stacked stone and spillway, 30 sf waterfall, 3 telescopic fountains, EZ Touch 8
    --Pentair VS3050, Whisperflo waterfall pump, Clean & Clear 520 cartridge filter, Intellibrite 5G LED lights, Ozone, Q360 in-floor cleaning, 400k btu heater
    --100 perim ft pool, 25 perim ft spa, Depth 3.5' to 7', 405 sq ft travertine decking, TF100 test kit
    --Time Lapse Video of our Pool Build ---- Our Pool Build Thread

  5. Back To Top    #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Stenner pump stopped working!

    Stenner has an exploded view on their website.
    It could be the drive pin worn off.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  6. Back To Top    #6
    JimboAZ's Avatar
    Join Date
    Oct 2012
    Location
    Maricopa, AZ
    Posts
    103

    Re: Stenner pump stopped working!

    Quote Originally Posted by Bama Rambler View Post
    Stenner has an exploded view on their website.
    It could be the drive pin worn off.
    I think you're correct. There is actually some rust on the gears so some water must've made it's way into the pump. I believe the gear post and/or one of the other gears is stripped. I can see some burring on one of them.

    I have found that Stenner support is very easy to reach and very helpful. When I have a few more minutes I'll call Stenner back and sort out the exact replacement parts needed. Thanks.
    --22k gallon pool/spa, IG, pebble w/ glass beads/abalone, all tile spa w/ stacked stone and spillway, 30 sf waterfall, 3 telescopic fountains, EZ Touch 8
    --Pentair VS3050, Whisperflo waterfall pump, Clean & Clear 520 cartridge filter, Intellibrite 5G LED lights, Ozone, Q360 in-floor cleaning, 400k btu heater
    --100 perim ft pool, 25 perim ft spa, Depth 3.5' to 7', 405 sq ft travertine decking, TF100 test kit
    --Time Lapse Video of our Pool Build ---- Our Pool Build Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •