Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Aqualnk RS4. Inop Pump button

  1. Back To Top    #1

    Join Date
    Apr 2014
    Plano, TX

    Aqualnk RS4. Inop Pump button

    Our home came with an Aqualink RS4 control panel. No problems other than the fact I can't get the pump button to respond. It's programmed to run from 7AM to 3PM daily. That's been fine but I don't have the option to change it. When I go into programming mode, it doesn't respond when selected. I also can't turn it on manually outside of programming mode via the control panel (I can via the PCB). To manually run the pump, I hit the "Cleaner" button to fire up the Polaris booster pump, which in turn force the main pump to come on. I'd like to fix this. Where do I begin? Seems like the button itself is out... I'm brand new to pools and pool equip.


    Edit: Turns out of I push hard enough, it will come on. Sounds like I may need to replace the control board, I'll follow up with the manufacturer.

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Houston, Texas

    Re: Aqualnk RS4. Inop Pump button

    Hi, welcome to TFP! Hopefully this will be an easy, inexpensive fix.
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts